No ringing whilst calling to external numbers

Hi there. I’ve been struggling with this but I’m in a dead end. I’ve read in this community about not ringing whilst external call reaches FreePBX, but in my case is just the opposite; there isn’t any ringing while placing an external call from an extension. It worked with the former main trunk, but a few days ago I set up a new one, no ringing is happening since.

Is this what’s happening?

You place a call to an external number and you hear nothing until the person at the other end picks up and says your local equivalent of “Hola.”

There are a couple of places this could be going wrong. The first is in the trunk definition. Add ‘Rr’ to the trunk dialing options - this will generate ring tones in the server in both directions.

There are also some options for when the audio stream picks up. I think it’s in the RTP settings. You may need to start the audio stream earlier. This article may help: Early Real-Time Protocol Info

Hi Dave, sorry it took so long to answer your post.

Yes, indeed. Adding ‘Rr’ to the trunk dialing options solved the problem. Any idea why this happened?

Thank you very much.

The choices you make in your server for Real Time Protocol (RTP) determine when the audio stream will start. Different start times mean that different things get to the phone at different phases in the call.

By supplying your own Ring Tone, you don’t have to worry about the remote switch supplying you ring tones, so you can start the RTP later.

Thanks :+1: