No ringback tone on outbound calls

When we make outgoing calls we don’t hear anything until the other person is connected. The usual tone you get (ringback) when the other phone is ringing isn’t there, but you can hear whatever is on the other end of the line when the call is answered. What steps to take to solve/investigate this issue? We have tried to add the prematuremedia=no property in the general section of the sip.conf file (sip_general_custom.conf to be exact) as suggested here and also added progressinband=yes to the trunk configuration as suggested here but with no success. What else should we check? It might even be a beginners mistake since we are new to FreePBX (version 11.7.0).
Thanks a lot.


does anyone have any ideas on this one?

thanks a lot!

Go to your trunk, look for “Asterisk Trunk Dial Options” add the ‘r’ option. Be warned though:

Generate a ringing tone for the calling party, passing no audio from the called channel(s) until one answers. Without this option, Asterisk will generate ring tones automatically where it is appropriate to do so; however, “r” will force Asterisk to generate ring tones, even if it is not appropriate. For example, if you used this option to force ringing but the line was busy the user would hear “RING RIBEEP BEEP BEEP” (thank you tzanger), which is potentially confusing and/or unprofessional. However, the option is necessary in a couple of places.

To clarify are your trunk and phones both sip

Thanks a lot for the tip! We have a ringback tone now. Maybe it’s not ideal in all situations but we can look for a better solution in time and for now we are very happy with it. :slight_smile:

Our trunk is a SIP Trunk with OVH and are phones are Yealink T26P.

Perhaps your SIP provider is not sending you the 180 Ringing response.

1 Like