No Ringback on inbound calls

when my system in called, the caller hears no ring back. Just dead air until someone answers. I worked with my sip provider support and what’s happening is that my system is sending both a 183 Session Progress and a 180 Ringing.

This would cause issues as the 183 states the equipment is going to be sending early media but then the 180 indicates the system is not expecting to send media.

is there a setting somewhere in the FreePBX gui or a CLI command in asterisk to change this behavior?

We should merge this with the three other threads asking exactly the same question.

Have you submitted a JIRA ticket yet? (Issues, above).

I haven’t submitted a ticket. Honestly not even sure where to submit it.

At the top of the Forums Screen - look for “FreePBX | Issues | Wiki | Portal | Support”.

Click “Issues” and log in with your forum username and password.

I have noted the recent reports, and have tested but have so far been unable to reproduce this, probably because it is provider specific. Thread offers a clue to the issue:

This ticket discusses a recent change to Ring Groups to include progress:

Roll back the Ring Groups module to earlier than 13.0.17 and test. You can re-open the above ticket to add comments.

1 Like

Rolled back to 13.0.16 and the issue seems to be fixed.

Almost all reports I have seen were google voice issues fixed by changing the codecs (putting gsm at the top)

“Ringing indication” can be turned off in inbound routes.

I have not had these issues no matter what settings I toggle and I don’t use google voice outside of their AUP or through back doors so I can’t say what will or won’t work for them

1 Like

James I had this issue before rolling back the ring group module and it was on purely internal calls (no trunk was in play). It could only be issue with some endpoints not all, really not sure. I would test it more if I could but too much on my plate at the moment.

Not using Google voice at all. Rollback of the ring group fixed it for me.

The edge version of Ring Groups (13.0.18) has a new option to enable/disable progress which should address the issued raised in this thread.To test:

fwconsole ma --edge upgrade ringgroups
fwconsole r