No notification of Trunk Down


#1

OK, my Trunk to my Provider goes down occasionally and will not come back up. I suspect it is a problem at my provider’s end, but that’s not determined yet. It happens once or twice a week at random times and I’m wondering how it is that my Trunk can be down and FreePBX will not give me any notification of this. Currently, I can recover this in one of two ways. a) switch to another trunk (I have three configured but only one active at a time) or b) reboot my FreePBX system (sometimes this doesn’t work). I do see my system trying every few minutes to reconnect. It’s hard to find it in my log because I don’t know where in the log to look and I don’t know what to look for normally.

So, two things:
a) why no easy indication that the trunk is down (I normally find out when I try to use the phone)
b) would like help with a process for shooting problems like this. I can get a rough time that it failed by going to my provider and seeing the last time it registered (it tries every 2 minutes).

I’m sure it’s my fault or maybe my provider (les.net), but I’ve not been able to find a configuration problem.

FreePBX 15.0.16.75
Asterisk 16.13.0
Trunks are PJSIP


#2

That code is ‘reactive’, if a call fails it might be triggered, (depending on the returned code.)

To be pro-active , that is much harder, not only does the trunk need to be responsive it also needs to be pro-active, i.e. only if it attempts a call to a number and that number reacts positively can it be considered “UP” You would have to poll for that condition, perhaps by calling one of your own DID’s.

To keep your clients happy, provide a ‘next route’ to cover failure and diagnose post-mortem the failed trunk.


#4

Thank you for getting back to me. This is for a home office so I’m OK with the trunk failing as long as it recovers. After it has fails, it retries every minute, and when working correctly, just reconnects, but when not working correctly it keeps failing until I discover the problem and intervene (switch to a different trunk).

How do you do a ‘next route’. I can just activate all 3 of my routes.

Anyway, It’s working now, but I think my best bet might be to leave it down next time and call my provider and ask what they are seeing. What my log sees in the following every 60 seconds.

WARNING[6905] res_pjsip_outbound_registration.c: No response received from ‘sip:sipserverip:5060’ on registration attempt to ‘sip:myacct@sipserverip:5060’, retrying in ‘60’


#5

Add to the trunk sequence in outbound route.

If the trunk doesnt ever self repair, perhaps your script could better be

fwconsole trunks --disable=n|mail -s oops your@email.com&&fwconsole reload


#6

Thanks, I’ve used the fwconsole command a lot, but never that variation. I’ll give it a shot manually the next time the problem occurs. I did notice that the beginning of the problem occurred this time at the same time that my router self reboots on Sunday morning at 5am, but that doesn’t explain why it didn’t eventually recover. Thanks again.