No network interfaces found

Finally installed the FreePbx 16 distro on a new physical box.
I used the automated install as graphical install gave me some onboard/external card headaches.
Using mobo UEFI option, onboard video.
At the beginning of install I see scrolling by
Not asking for VNC because we don’t have a network…
Option 7: Network configuration is unchecked, underneath it says (No network devices available)
After successful installation of FreePbx distro, I log in.
There is not network connection, no ip address assigned. I don’t see it on my router.
lspci does show:
Ethernet controller: Realtek Semiconductor co… … Controller (rev 04)
I tried two different ethernet cables, tried my switch and then a cable directly to my router.

It might be something with the drivers on your server. Try to get the card brand/model and look for driver for that specific card for CentOS distros and install them.

Given the OP is using ‘the distro’, then

‘It might be something with the drivers on your server.’

might better be put as

'It might be something with the drivers on our iso ’

compound support for missing video drivers also


1 Like

Yeah, I thought the distro supported the basic mobo drivers during installation. I understand new mobos make that a challenge, but I don’t want to use my 3yo hardware.
I’ve Googled for FreePbx distro compatible (current generation) full size ATX mobo lists, but nothing really out there. I realize that would be a challenge too, but even one mobo/cpu combination I could buy on Newegg is good enough for me. That is one of the beauties of the PC Part Picker website for building new machines. You know, using that, your system will boot.
I’ll look for bios updates and install.
I’ll try looking for networking drivers for CentOs.
I’ll re-do the Rocky mini OS install and confirm the ethernet works, like the video did.
I ordered a PCI-e ethernet card, maybe I can just use that with driver autodetect?
If not, I guess I’ll wait on a new version of the FreePbx distro with updated OS support. I’m not in a rush, maybe my mobo will be old enough by then to be supported better.
Not planning on cloud Pbx at this time.
Any other thoughts to fix?

Finally have my FreePbx 16 distro installed on a MSI Z490-A-PRO Mobo

  1. Used Fully Automated installation since my onboard video is not fully supported. Automated install is text based and uses a default password SangomaDefaultPassword. If your monitor screen goes blank after you’ve let the install go on a while, just press space on your keyboard to see if you can reboot yet.
  2. Prior to installing distro, I installed a tp-link gigabit PCI Express Network Adapter TG-3468. The Distro installed it automatically.

Only took 5 minutes! LOL

Glad you got it working, marking it as a ‘solution’ ,hmm, I would describe it more as as competent ‘work around’

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.