No MOH with calls on hold but MOH Does work with parked calls. Please help

Hi,

I’m trying to setup a new box on 2.10 but I’m having issues with MOH. The MOH plays fine on parked calls but not when a call is placed on hold. Basically there is just silence and after a while the system hangs up. Looking at Asterisk it doesn’t even show the line being put on hold. Below is a inbound call which is answered, put on hold twice and then the caller hangs up while on hold. There is no reference to MOH at all.

I hope someone here can point me in the right direction.

Thanks in advance!

– Called SIP/240
– SIP/5711-00000051 connected line has changed. Saving it until answer for DAHDI/3-1
– SIP/4803-00000052 connected line has changed. Saving it until answer for DAHDI/3-1
– SIP/240-00000053 connected line has changed. Saving it until answer for D AHDI/3-1
– SIP/4803-00000052 is ringing
– SIP/5711-00000051 is ringing
– SIP/240-00000053 is ringing
– SIP/5711-00000051 is ringing
– SIP/240-00000053 connected line has changed. Saving it until answer for D AHDI/3-1
– SIP/240-00000053 answered DAHDI/3-1
– Executing [[email protected]:1] Macro(“DAHDI/3-1”, “hangupcall,”) in new s tack
– Executing [[email protected]:1] GotoIf(“DAHDI/3-1”, “1?theend”) in new s tack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] Hangup(“DAHDI/3-1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘DAHDI/3-1’ in macro ‘hangupcall’
== Spawn extension (macro-dial-one, h, 1) exited non-zero on ‘DAHDI/3-1’
== Spawn extension (macro-dial-one, s, 42) exited non-zero on ‘DAHDI/3-1’ in m acro ‘dial-one’
== Spawn extension (macro-exten-vm, s, 14) exited non-zero on ‘DAHDI/3-1’ in m acro ‘exten-vm’
== Spawn extension (from-did-direct, 233, 2) exited non-zero on ‘DAHDI/3-1’
– Hanging up on ‘DAHDI/3-1’
– Hungup ‘DAHDI/3-1’