No matching endpoint found

I am setting up a new PBX but after forwarding the incoming SIP calls to my PBX IP
I am getting these error lines in Asterisk log

[2017-08-25 16:45:17] NOTICE[6413]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘INVITE’ from ‘sip:[email protected];pstn-params=8084818088;cpc=ordinary’ failed for ‘200.126.52.37:5060’ (callid: [email protected]) - No matching endpoint found
[2017-08-25 16:45:17] NOTICE[6413]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘INVITE’ from ‘sip:[email protected];pstn-params=8084818088;cpc=ordinary’ failed for ‘204.10.205.149:5060’ (callid: [email protected]) - No matching endpoint found
[2017-08-25 16:45:26] NOTICE[6413]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘INVITE’ from ‘“101” sip:[email protected]’ failed for ‘158.69.251.14:5070’ (callid: a6923d0b94488185c4426e998b7433b5) -

In FreePBX and Asterisk configuration, the term “SIP” can be considered largely meaningless with the advent of both SIP Channel Drivers (ChanSIP and PJ-SIP).

From a connecting phone perspective, your incoming traffic is arriving on a port (probably 5060), and one of these two channel drivers may be connected to your port 5060. Your other channel driver is connected to another port (5160 for example). Let’s assume you used the defaults and everything is setup “vanilla”.

The PJ-SIP channel driver is allocated to port 5060.
The ChanSIP channel driver is allocation to port 5160.

If you set up the extensions for your phones as “ChanSIP” extensions, they are listening for connections on port 5160, but chances are (as this is common with most phones) they are trying to connect on port 5060. Since the PJ-SIP channel driver is connected on port 5060 (by default), there are no extensions to connect to there.

This becomes even more important to understand as you get more sophisticated in your extension connection process, since one of the advanced configuration recommendations is to not use 5060 for connections that are open to the Internet. This reduces “script kiddy” activity and improves your system’s performance.

So, figure out which channel driver is connected to which port, and set up your extensions on that port in that channel driver. I bet the problem goes away.

Thank you, it seems to be working now but I am getting the error message
that is probably caused by a different issue
– Executing [[email protected]:5] Playback(“PJSIP/Convergia-00000007”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack

Yup. You need to finish setting up your outbound routes and trunks.