"No matching endpoint found" on some extensions, but not all

I have a new deployment and am running into some issues I haven’t experienced before. I have a number pf pjsip extensions registered. All were working fine but then a few of them have stopped being able to place calls internally, externally, to voicemail…nothing. Gives me a “busy” signal immediately They can still receive calls just fine, though. Here’s an example of what I’m getting.

This extension looked like it was being banned by fail2ban at one point but I whitelisted it and I’m still having the same problem. Other extensions work just fine but the problem has spread to three different extensions and I’m concerned that it will continue given enough use. Not sure what’s causing them to drop off. I’ve searched for solutions quite a bit and am stumped. Any help you could provide would be appreciated and if there is other info I can post I’d be happy to. Thanks!

Did you restart fail2ban after doing so?

Yes. Restarted and it’s not showing any IP’s as being blocked. Interestingly, it only ever showed the one IP as being blocked even though multiple extensions are experiencing the same issue.

Try to place a call, and post the call logs here.

I might be misunderstanding you, but outbound calls don’t seem to be generating any logs other than what I provided in my original post. Calls from other working extensions in the office do create records.

Red Herring. This isn’t a firewall problem. It’s a Chan-SIP/PJ-SIP problem.

There are two SIP drivers on your server. One connects to port 5060 and one connects to port 5160.

Your phone are connecting to port 5060, but the extensions in the PBX are (probably) configured in the SIP driver that is connected to port 5160.

Thanks for the reply. I was thinking it was likely an issue with the SIP driver as well, but have (I think) checked and double checked, etc, etc, to make sure everything matched, between the phone and the server and I’m not seeing a disparity between the driver in use and the port on the server/phone. Also, all phones are programmed the same way…none of them had issues when I first installed…it wasn’t until I started in on making some test calls and programming some features that I started having issues with individual extensions becoming unusable.

One more screenshot from the phone’s settings. It’s a Grandstream GXP2160.


The Local SIP Port is the port on the phone that you are talking to. The SIP port on the server is 5060. They are coincidentally the same.

I don’t see anything about your actual registration information, but if you are getting that error, it means that the extension is not configured for the Channel Driver you are actually connecting to.

The GXP2160 rings a bell for me - I think we’ve been hearing about problems with the 2160 and PJ-SIP over the past couple of months. Search for 2160 in the archive here and see what pops up. If my recollection is correct, you may need to change the phones so they register in Chan-SIP.

1 Like

Great…ok, thank you for the feedback. I feel like I tried switching it over to Chan-SIP somewhere along the way but I’ll search around in the forum on that phone specifically and will give it a go next time I’m onsite. Thanks again!

So either something isn’t working correctly or I’m not doing this the right way or I’m just missing something obvious…or all of the above…but I can’t get an extension to register as Chan-SIP. I created the new extension in FreePBX as Chan-SIP and entered the User ID and secret on the Grandstream…no dice. I tried changing the port in the Extension’s advanced settings to match what I found in the Grandstream’s settings…no dice. I’m guessing this is a misunderstanding of port settings between FreePBX, Asterisk and the device, but I’m stumped.

I have 2160’s and 2170’s on that run on ChanSIP here. You could post the other configuration screens for the account and I could look for anything that seems out of whack.

Yeah, I’d really appreciate that. What screens would be best to send your way?

The account configuration screens. Given that you can receive calls but not make them, I’m not sure what the problem is though.

Thanks for the offer to help on this one. I was able to figure out the issue with registering as a ChanSIP extension…I hadn’t added toe port onto the end of the Outbound Proxy IP. That seems to have done the job. Waiting to mark this one solved, however, until I see the original issue corrected through some some sustained usage. Thanks again for everyone’s help.

Yeah, looks like getting things switched over to ChanSIP did the job. Thanks again, everyone.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.