No logging to /var/log/asterisk/full

Hey guys,

Been struggling with this one this morning, I’ve just restored a backup (created from a system that was installed 2.9, updated to 2.10) onto a fresh 2.10 installation and now I find that I have no logging to /var/log/asterisk/full.

/etc/asterisk/logger_logfiles_additional.conf is empty, where on my other systems it contains messages => and full => with notice,error,debug,verbose etc. I’ve tried playing with the ‘Additional settings’ options verbose logging on/off and freepbx logging on/off to no effect.

If I remove logger_logfiles_additional.conf and reload FreePBX, the file is recreated but still empty. And if I manually add the lines and reload, the lines are removed. If I manually add the lines to logger_logfiles_custom.conf, logging works but VERBOSE logging does not - I only get NOTICE etc. messages, no VERBOSE.

Thinking this was a rogue setting leftover from the 2.9-2.10 upgrade I’ve checked out the freepbx-settings table in the database and compared it to another fresh 2.10 install I made yesterday but there were only a few minor differences that were not related to logs, I corrected them but it’s made no difference.

Can anyone point me in the right direction to look?

Many thanks.

Your guess is as good as mine if you don’t send the output of the ‘logger show channels’ command.

Hi Skyking,

Thanks for the reply, I’ve not used Asterisk CLI commands much so wasn’t aware of that one. This is after I’ve added the lines to /etc/asterisk/logger_logfiles_custom.conf as they keep disappearing from logger_logfiles_additional.conf

host2*CLI> logger show channels
Channel Type Status Configuration

/var/log/asterisk/fail2ban File Enabled - NOTICE
/var/log/asterisk/full File Enabled - DEBUG NOTICE WARNING ERROR VERBOSE

Unfortunately it seems like all should be fine.

This is the content now of my logger_logfiles_custom file:
console => notice,warning,error
full => notice,warning,error,debug,verbose
fail2ban => notice

Thanks for any suggestions

Can Asterisk write to the folder? Folder must be owned by Asterisk and have full read and write privs.

Hi SkykingOH,

The folder is owned by asterisk and it has full read/write privileges.

If I manually add the lines to logger_logfiles_custom (as above), the other levels (DEBUG, NOTICE) get written to /var/log/asterisk/full and only VERBOSE does not. However on all of my other 2.10 machines, logger_logfiles_additional doesn’t get emptied when I reload FreePBX - so I believe the two problems must be related. Something that got restored from the backup (from the 2.9->2.10 machine) has gone awry.

I’m just not sure where to look for something that might be wrong, as I checked out the settings table in the database which was ok. The backup files I’m using don’t contain any other files than the CDR SQL, the settings SQL and voicemail messages. Prior to restoring the backup, the installation was working fine.

Perhaps there’s something else in the SQL database I’ve missed?

Thanks for your reply

Sorry, I’ve just noticed that on my test system (with this problem, the other is in production) if I remove logger_logfiles_custom.conf, logger_logfiles_additional.conf is rewritten correctly. And if I add anything to _custom.conf, _additional.conf is then emptied again upon reload. This behaviour seems to be replicated on my other servers, so if it isn’t a bug then I must have missed that.

That explains that at least, however unfortunately on the system in question (but not the others), I still get no VERBOSE logging whether using all the lines in _custom.conf or just the default lines in _additional.conf. At least the picture is a little clearer now.

ADD: Problem solved this morning, I got in an early reboot and recompiled Asterisk (10.5.1) and all is working fine now. Strange!