No internet access. eth0 and eth1 setup chalanges

Good Afternoon.

We recently purchased a Sangoma FREE PBX 60

I got a problem. We have recently had Ethernet installed. it has a dedicated connection for the SIP trunks to my ISP.

Basically they gave me a static IP a netmask and gateway to set in my asterisk server. All is fine it works as it should.

But that gateway has no internet access and I’m having trouble connecting my Asterisk to the internet. I cant run updates and I can’t connect off site extensions.
Only extensions on my local network to my freepbx IP

Here is details of my setup:

eth1 (no access to internet only to private network from my ISP):


eth0 (connected to my local network that has access to internet)


Now I’ve tried changing default gateway on my asterisk, but then VOIP doesn’t work, but I can update the system. So whenever I wanna run an update I have to change the main gateway to and then back. Also I can’t get an external extension to connect to matter what I do.

Please help

You need to add a route to via using eth1 and have the default route through via eth0

Thank you for the reply.
How do I do that. I have tried a few things, however it failed. Any advice?

Sorry I don’t which "few things your tried " or why "it failed"
I would start with

man ip

I have addd those routes to: /etc/sysconfig/network-scripts/route-eth0

how did the

man ip

work out for you?

ip route
ip route add help
ip route add via
ip route
ip route change default via
ip route

thanks for that.
when i set the default IP to i cant make or recieve calls
the SIP provider ip is:

Then broaden the route to

that resolved that problem. my internal extensions can now make and receive calls. however my remote extensions that connects to the server via eth0 from the internet, has no audio. they can register, but their is no audio when making or receiving calls.

Configure your sip nat options. Search the forums for exact instructions.