FreePBX | Register | Issues | Wiki | Portal | Support

No incoming voice during calls


(Mike Kasprzak) #1

Hey guys!

I’ve got a big big problem here. In the last week we’ve had a problem in our company, probably related to the hard drive in our VoIP server. We’ve replaced the HDD and installed a new copy of FreePBX with Asterisk 13 (earlier there was some kind of an archaic version of FreePBX with Asterisk 6 if I’m not wrong, and it was installed there by external company).

The problem is that after this upgrade in some cases the consultant in our call center doesn’t hear anything from the other side. For example, if our employee calls me on my mobile phone, I can hear him, but he can’t hear me. What’s important is the fact, that in the recording of this call you can hear both of us. But in the phone there’s only silence.

We are using SIP and IAX GSM trunks and different models of Yealink phones (also this VoIP server is connected with our PBX in other city via IAX), and I don’t think it’s the problem with codecs (everything is rather configured to use for example PCMA/alaw codec). Also it shouldn’t be related to the firewall - I didn’t turn on the FreePBX firewall and firewall in our router shouldn’t be the problem there too, because our network with phones and PBX can work without it (static IPs, connected through switches).

I’ve tried switching from PJSIP back to the legacy SIP but it didn’t help.

It’s very strange problem, because it works in some cases, and in some it doesn’t, and it doesn’t seem that there is any rule for that (it’s not even related to only incoming or outbound calls, it happens in both cases :confused:).

Do you happen to know, what can be the source of the problem here? If you need any additional information please tell me.


(Dave Burgess) #2

I have a similar system issue with Voip Innovations (not their fault, it’s just a problem). When I receive a call that gets passed back out from my server, to VI, I consistently get one-way audio.

My solution was to add a second VOIP provider for the outbound leg to all of the cell phones connected to my network.

Note that the reflected route should work, and there are probably settings that can make it work, but I found a simple work-around that you can test and try. If it doesn’t work, you’re out a couple bucks and ten minutes.