No incoming calls


I have just Setup FreePBX Distro and have configured a trunk for a Draytel account, added an Inbound and Outbound rule and given it a test. Outgoing calls from soft-phones (connected to the PBX) to external numbers work fine (we have been testing with a mobile phone), but when phoning the PBX from the mobile, we just get a Busy tone and call is cancelled.

We have spoken to Draytel about this who, although being helpful weren’t able to get us any further as they claimed they didn’t know anything about FreePBX. They setup the account their end though and we tested the same number from my mobile and it rang - so we know there is nothing wrong with our account.

We have added extensions to the PBX and the softphones are connecting fine with these details. We have just one inbound rule setup which forwards to an extension.

We cannot find any mention of any incoming calls in any of the logs, so we are a bit stumped as to where to look next.

Any help would be appreciated. Just let me know what info you need.

Outbound works but inbound fails…I would check any intervening firewall(s) on the network…especially since the logs show nothing for inbound like it isn’t hitting the server.

  1. what does your trunk config look like?
  2. what does your firewall/router config look like?

it sounds like a firewall issue. remember there are a set of udp ports that must be forwarded to your pbx. if you don’e have remote phones then allow the sip and rtp ports through the firewall only from your ITSP.

Have a look here for Draytel Asterisk trunk setup:

Thank you for your comments.

Leemason, thanks for the link. That is where I first went to and obtained the settings I am now using.

I too am pretty sure it is a firewall issue. I have now tried a different router which is pretty basic. The previous router was being used as the PBX and I was wondered if that might be blocking something getting through despite turning off as much as I could see.

BKSales, You can see my trunk setup here:
I have starred out my secret. Please give more details on which ports I need to open/forward as I haven’t found out any concrete on what needs to be done.

Many thanks.

Do you get anything in the Asterisk log file when you make an inbound call? Also have you tried turning SIP debug on to see what happens?

Sorry, I haven’t had a lot of time to play with this recently.

Can someone tell me which ports I need to open/forward on my router?

I dont think your trunk settings are in the correct order. I recall sequence was important
open port tcp 5060
udp 10000-20000

thank you so much jeff-405, I think I’m nearly there.

Just changing the trunk settings along didn’t help, I also needed to alter some settings on our Draytek Vigor IPPBX 2820 router because (being a PBX router itself) I don’t think it was allowing through all the ports despite them being open.

I now have some random calls coming in though from 5555, 1000, 2222, 4444, 3333, 1001. If we answer them, there is just silence the other end. Does anyone know what these might be, and how to stop them?

Kind regards,


The random calls are most likely hackers probing your system. When you forwarded port 5060 did you allow it from all hosts (a bad idea) or just from you SIP provider?

Rawden - Those are folks probing your system because you have it “wide open” on the Internet. Try to only forward your carriers IP’s

Many thanks for your suggestions. I will try and lock down the port.

We are using Bria 3 softphones and receive BLF presence for Ready, On the Phone, Ringing etc. but not when we ‘manually’ change status from within the software, i.e. select DND or Busy.

Is this something that needs tweaking in Asterix, or Bria? I’m not sure if this should normally work out-of-the-box or not.

I’m going to quess and hopefully save you some time. I had the same problem and recorded between 480-650 hours of unpaid work till i found something that worked.
at first i was not able to get any inbound calls busy signal or disconnected or just just not ring. The above thread was the fix for me. I would recommend you make sure your sip settings are set to default unless you fully know the change is needed then disable your firewall on the modem. Purchase a hub that not a router or a different brand router like Linksys then update your globals,Gateway, ip addr of the phone server and Dns in the phone,asterisk sip settings,endpoint configuration manager and sysadmin-network freepbx. Keep in mind that sometimes your setting will not take change immediately with out stopping asterisk, running service network restart and most importantly unplug your modem then wait for it to boot then plug in the router or hub.You could end up eliminating with out actually confirming the change took affect. Try to obtain trunk registration and outbound calls then make just one change at a time so you know the results. For me i did not have to change a thing but get rid of the dlink router. I was able to find routers still in the box for 6.99 at goodwill if you have anything like that in your state

Hi Jeff-405,

Thanks for the extra help with no incoming calls, but I sorted that problem after your trunk setting change suggestion and the disabling sip on my router mid-May. It’s just the presence issue I have now.

Apologies if I sound ungrateful.

Hi rawden,

Did you ever get this to work?
I am suffering the same problem only I do not have a DrayTek router like you.
I have the latest Distro FreePBX and most of the docs are for much earlier versions so I’m struggling a bit.

After five years, one would hope he got it fixed.

You really need to start your own thread.

I Did and you are responding to it.
I just thought I’d ask you never know :wink: