No incoming calls from SIP provider when using PEER details "qualify=no"

I’m running FPBX-2.11.0(11.15.0) behind a firewall with the general Asterisk settings set “nat=yes”, and have setup several trunks to diffierent SIP providers where I have for every trunk configuration in their PEER details amongst other lines also


and the respective correct connection string.

With this setup I am able receive calls without any problems, can ping the SIP server with its “host” name, and when executing the command “sip show peers” on the Asterisk console, I can see under the “Status” column a message “OK” (with the respone dealy in ms).

Today, I’m running into a situation that another SIP provider refuses me to ping their “host” destination and is asking me to put for their trunk configuration in the PEER details


and the respective correct connection string, what I’ve done.

This done, I’am not able to receive any calls at all through this trunk, even I do not find any log entry of an incoming call in the /var/log/asterisk/full file or any messages when when running “asterisk -rvvvv”.

I raised to the provider the issue of not being able to receive calls, and that I cannot ping their “host”, however they claim that their security policy does not allow any of their customers to ping their servers, to quote “Customer’s have to setup their devices or systems properly to be able to receive calls through their trunks.”

So here I’m stranded now, I’ve tried several PEER config parameters, however no luck…

Did anybody face the same situation in the past or have any recommendation here on how to setup a trunk configuraton for a SIP provider as described above?

qualify=yes does not send “pings” in the form of ICMP echo requests. It sends a SIP qualify packet, which is used to determine the availability of the host. It’s also used to ensure pinning open NAT holes, should you be using NAT (is the Asterisk server on a private IP, and peer on public?) If NAT is in play, you’ll want to use qualify=yes . If it works when qualify=yes, then there’s a reason for that. If your provider tells you, “Well, it’s working - but don’t use that. Use this!” then they’re simply stupid. You’d be amazed how many SIP providers are completely incapable of giving you decent service and completely lack the basic fundamentals of the technologies they’re selling. :wink:

Thank you for the feedback on this, and yes my Asterisk is NATed and behind a firewall.

I have setup the same peer configuration with the “qualify=yes” parameter of the bespoken VoIP provider, and still the same issues, no incoming calls :frowning:

In the meantime, I’ve found in interesting article under the URL


about the required “qualifly=yes” setup when using Asterisk behind teh NAT, to quote:

“The addition of qualify=yes causes Asterisk to test the connection frequently so that the NAT translations are not removed from the firewall. With these two commands, there always will be a communications channel between Asterisk and the peer, and Asterisk will use the outside address when sending SDP messages.”

However, the VoiP provides urges me to set “qualifly=no”, and is now asking me to install Wireshark, and troubleshoot myself to see whether I see any incoming packets when calling the provider’s trunk …

Weird explanation :flushed: