No inbound sound

I have fully functioning asterisk 11.1 running under xen on arch linux.
I had created another vm for freepbx with same ip address so I can add freepbx. I had installed freepbx and asterisk 11.1
I can make calls and both sides can hear each others. I added local and remote addresses to sip settings. Any incoming call will be silent. The calls come in fine on asterisk but when I shutdown asterisk system and start freepbx incoming calls have no sound. I had to remove nat=no from extensions and I had added proper nat= setting to sip.conf and phones behind my pfsense firewall work fine they can make calls with sound. With nat=no in extensions there was no sound.
Can somone point me in right direction to get my sound back on incoming calls.

You do realize that by using an unsupported (by the FreePBX team) version of Linux you are in completely uncharted waters?

To me it is amazing you have gotten this far, you must either be a Linux guru or have the best luck of any human being on the planet

As far as your NAT problem, you didn’t tell us what kind of phone or describe the network topology at either end so it is difficult to hazard a guess.

When you created the second VM, did you clone the MAC address or change it? If you cloned it and are running it on the same network as the original VM at the same time, you’re going to run into all sorts of trouble.

Typically, FreePBX and Asterisk are run in CentOS. My knowledge of Linux is limited to CentOS, so I can’t help you beyond what I just told you (above).

I have two linksys PAP2 connected to freepbx on inside and voipms and google voice.
I am getting app_dial.c:2433 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent

triton777? Why do you ignore peoples comments? The last person helping you asked a question about your network config.

The error messages are because of network issues.

It strange that softphone works fine and I get audio both ways. When I use ata addapters linksys pap2 I don’t get any sound. I also noticed permission issue I have to change mod 755 on all files in /var/lib/asterisk/agi-bin after applying changes in web interface otherwise scripts can’t be executed and any incoming calls goes to voice mail.

I get this error and calls disconnects
[2012-12-24 20:47:28] NOTICE[1991]: chan_sip.c:28519 check_rtp_timeout: Disconnecting call ‘SIP/101-00000001’ for lack of RTP activity in 31 seconds

Well looks like the question was what kind of phone is it linksys pap2
I have static external ip address i use fro local ip addresses I have server 2012 that acts as domain controller and dhcp server. I had tested External soft phones on outside of my pf sense and android voip clients. Internal soft phone receive audio both ways. Both linksys pap2 can place calls with full audio.
Well it interesting that softphone xlite works fine on same extension as linksys pap but linksys pap2 gets no sound on incoming call, but full audio on outgoing.
I don’t belive that my distro has nothing to do with this error after all asterisk 11.1 works fine without freepbx.
What more detail I can provided about my network topology.

If bare bones Asterisk works and it doesn’t work configured by FreePBX the you have something different in sip general config or trunk config.

Review the NAT setting in SIP settings module.

Well everything is fine now I added port 5060 and bind address sip configuration and both of mine linksys pap2 work fine. Now I also have dlink vtv adapter that worked fine with asterisk but there is no sound on incoming calls on it.