No inbound Freepbx and Voip.ms

Please help i have No inbound Freepbx and Voip.ms. outbound is working…
freepbx version
PBX Firmware:12.7.4-1803-1.sng7
PBX Service Pack:1.0.0.0

Firewall is off but it seem like freepbx is rejecting the sip ip address
do i need to add it somewhere??

OUTBOUND PEER DETAILS
canreinvite=yes
nat=yes
context=from-trunk
host=newyork5.voip.ms
username=2xxxxx
fromuser=2xxxxx
secret=xxxxxx
type=peer
disallow=all
allow=ulaw&g729
trustrpid=yes
sendrpid=yes
insecure=invite
qualify=yes

Outbound dialing pattern
NXXNXXXXXX
NXXXXXX
911

Host dnsmgr Username Refresh State Reg.Time
newyork5.voip.ms:5060 Y 2xxxxx 105 Registered Wed, 21 Mar 2018 12:44:51
1 SIP registrations.

Error MSG

[2018-03-21 12:56:48] VERBOSE[25772] cel_odbc.c: Found CEL table [email protected]
[2018-03-21 12:56:48] VERBOSE[25772] loader.c: Reloading module ‘app_playback.so’ (Sound File Playback Application)
[2018-03-21 12:56:48] VERBOSE[25772] loader.c: Reloading module ‘app_voicemail.so’ (Comedian Mail (Voicemail System))
[2018-03-21 12:56:48] VERBOSE[25772] config.c: Parsing ‘/etc/asterisk/voicemail.conf’: Found
[2018-03-21 12:56:48] WARNING[25772] app_voicemail.c: maxsilence should be less than minsecs or you may get empty messages
[2018-03-21 12:56:48] VERBOSE[25772] loader.c: Reloading module ‘app_flite.so’ (Flite TTS Interface)
[2018-03-21 12:56:48] WARNING[25772] app_flite.c: Flite: Unable to read config file flite.conf. Using default settings
[2018-03-21 12:56:48] VERBOSE[25772] loader.c: Reloading module ‘codec_dahdi.so’ (Generic DAHDI Transcoder Codec Translator)
[2018-03-21 12:56:48] VERBOSE[25772] loader.c: Reloading module ‘app_queue.so’ (True Call Queueing)
[2018-03-21 12:56:48] NOTICE[25772] app_queue.c: queuerules.conf has not changed since it was last loaded. Not taking any action.
[2018-03-21 12:56:48] VERBOSE[25772] config.c: Parsing ‘/etc/asterisk/queues.conf’: Found
[2018-03-21 12:56:48] VERBOSE[25772] config.c: Parsing ‘/etc/asterisk/queues_general_additional.conf’: Found
[2018-03-21 12:56:48] VERBOSE[25772] config.c: Parsing ‘/etc/asterisk/queues_custom_general.conf’: Found
[2018-03-21 12:56:48] VERBOSE[25772] config.c: Parsing ‘/etc/asterisk/queues_custom.conf’: Found
[2018-03-21 12:56:48] VERBOSE[25772] config.c: Parsing ‘/etc/asterisk/queues_additional.conf’: Found
[2018-03-21 12:56:48] VERBOSE[25772] config.c: Parsing ‘/etc/asterisk/queues_post_custom.conf’: Found
[2018-03-21 12:56:48] VERBOSE[25772] asterisk.c: Remote UNIX connection disconnected
[2018-03-21 12:56:48] VERBOSE[12763] config.c: Parsing ‘/etc/asterisk/sip_notify.conf’: Found
[2018-03-21 12:56:48] VERBOSE[12763] config.c: Parsing ‘/etc/asterisk/sip_notify_custom.conf’: Found
[2018-03-21 12:56:48] VERBOSE[12763] config.c: Parsing ‘/etc/asterisk/sip_notify_additional.conf’: Found
[2018-03-21 12:57:50] NOTICE[12763] chan_sip.c: Peer ‘voip.ms’ is now Lagged. (2038ms / 2000ms)
[2018-03-21 12:57:53] VERBOSE[12763][C-00000005] netsock2.c: Using SIP RTP TOS bits 184
[2018-03-21 12:57:53] VERBOSE[12763][C-00000005] netsock2.c: Using SIP RTP CoS mark 5
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:1] NoOp(“SIP/23.29.136.28-00000007”, “Received incoming SIP connection from unknown peer to 2035833636”) in new stack
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:2] Set(“SIP/23.29.136.28-00000007”, “DID=2035833636”) in new stack
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:3] Goto(“SIP/23.29.136.28-00000007”, “s,1”) in new stack
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx_builtins.c: Goto (from-sip-external,s,1)
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:1] GotoIf(“SIP/23.29.136.28-00000007”, “1?setlanguage:checkanon”) in new stack
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx_builtins.c: Goto (from-sip-external,s,2)
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:2] Set(“SIP/23.29.136.28-00000007”, “CHANNEL(language)=en”) in new stack
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:3] GotoIf(“SIP/23.29.136.28-00000007”, “1?noanonymous”) in new stack
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx_builtins.c: Goto (from-sip-external,s,5)
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:5] Set(“SIP/23.29.136.28-00000007”, “TIMEOUT(absolute)=15”) in new stack
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] func_timeout.c: Channel will hangup at 2018-03-21 12:58:08.024 EDT.
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:6] Log(“SIP/23.29.136.28-00000007”, "WARNING,“Rejecting unknown SIP connection from 23.29.136.28"”) in new stack
[2018-03-21 12:57:53] WARNING[26050][C-00000005] Ext. s: “Rejecting unknown SIP connection from 23.29.136.28”
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:7] Answer(“SIP/23.29.136.28-00000007”, “”) in new stack
[2018-03-21 12:57:53] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:8] Wait(“SIP/23.29.136.28-00000007”, “2”) in new stack
[2018-03-21 12:57:55] VERBOSE[26050][C-00000005] pbx.c: Executing [[email protected]:9] Playback(“SIP/23.29.136.28-00000007”, “ss-noservice”) in new stack
[2018-03-21 12:57:55] VERBOSE[26050][C-00000005] file.c: <SIP/23.29.136.28-00000007> Playing ‘ss-noservice.ulaw’ (language ‘en’)

You don’t have an inbound trunk for that host, so the call is considered anonymous, which it looks like you are blocking. All in all, it looks like the system is working.

Turning on the integrated firewall, assigning that address to the trusted zone, and adding an inbound trunk for that IP should get you on your way.

1 Like

Thank you… in my inbound route i was putting my phone number in the incoming did field thanks… Removed it and left ANY working now thanks

If you check your logs now, there will be a warning about (basically) “This is the number we received, you should set up an inbound route to match.” That is the DID your ITSP is sending. It may be different than what you were expecting.

Putting that ip address of the sip server in the firewall as a “internet default firewall” seems to be working… Is that setting okay as far as security is concerned ?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.