No inbound calls on T1


I am having problems with no incoming calls working on a T1. I’m really pulling my hair out on this one and I don’t have much to begin with. Most issues I’ve seen (or read about) are related to no destination for inbound calls.

  • the error is "the number you reached is not in service’
  • is it odd that the error msg changes slightly depending if I call from cell, analog landline, or my asterisk box? always some slight variation of the not in service or unavailable msg
  • I can make outgoing calls across the T1
  • previously I had some FXO cards (A400P)installed and could make incoming/outgoing calls, these were swapped out for a Digium TE121B
  • according to my service provider the T1 is good, tested when installed for incoming/outgoing
  • right now the calls go Time Group> Time Condition> IVR
  • I tried changing my inbound route to go to a single extension, same error message

Basically this is a new install of Asterisk 1.7.1 with Freepbx The initial install was some OpenVox A400P FXO cards but I could not get rid of a bad case of echo. The plan was to move to a T1 to condense the line cost and then in a year or two convert over to SIP service - the office wants to adopt new technology but at a slow pace.

If you leave the DID blank in inbound routes it creates a “catch all” route that will match all of your DID’s

The more important thing is how did you end up with “incoming” as your context?

It looks like the issue was the ‘context = from pstn’ in the chan_dahdi.conf I can now dial into the PBX - thanks! I was trolling through some other sites once I knew the error msg but had not come upon that as a fix.

Can you confirm for me: by leaving the DID section of the incoming route blank that allows all numbers (local/long distance) access, this is in reference to your ‘… have a route for your 702 number’ comment.

Thanks for the directions. My msg is

– Extension ‘702xxxxxxx’ in context ‘incoming’ from ‘702xxxxxxx’ does not exist. Rejecting call on channel 0/1, span 1

for clarity the xxxx’s are replacing valid numbers. This makes it sound like a bad incoming route issue. I tried adding the inbound extension to the DID field and the Caller ID Number individually as well as both. Same error kept coming up when I dialed from an outside line.

While not resolved I am thankful for a direction to head. If you’ve got more ideas throw them my way.

You need to set your context to “from-pstn” the context “incoming” is not valid.

Make sure you have a route for your 702 number.

That’s the step I’m trying to figure out now. I was trying to look at a log file earlier but it was massive (/var/log/asterisk/full). I may have been looking at the wrong log though. Am I correct in choosing ‘logger verbose’ to get more junk recorded and ‘logger mute’ to turn it off?

I don’t know where “logger verbose” and “logger mute” are.

Just run the Asterisk CLI with ‘asterisk -r’

You set the verbosity level with 'core set verbose 8" 8 or 16 should get you the detail you need. This way you can cut and paste just the relevant log excerpt. If using putty to SSH into the system you may want to turn up the screen capture buffer beyond the 200 that is default.

Can you post log output when you try and call the system? Do you see the call hitting the box?

While I don’t think it the issue is here I’ve listed my chan_dahdi.conf and system.conf



; include dahdi extensions defined in FreePBX
#include chan_dahdi_additional.conf

; T1
context = incoming
signalling = pri_cpe
switchtype = national
echocancel = yes
group = 1
channel = 1-23