No GUI Access - You don't have permission to access /.noindex.html on this server

Running FreePBX 14. I am able to access the server via SSH and calls are processing but have no GUI access even after a reboot, before the firewall starts. I’m getting the following error:

You don’t have permission to access /.noindex.html on this server.

I’ve already ran a fwconsole chown and rebooted, no luck. What should I be looking at doing next to resolve this?

Thank you.

Check the port you are accessing on. For example, should you be accessing the GUI with http://FQDN:2468 or http://IP:2468? The port I give is an example. The port is set in SysAdmin with port 80 as the system default.

Hi @kierknoby

The web port is set to port 80, I believe. I have tried accessing the GUI via http://IP-ADDRESS and https://IP-ADDRESS to no avail.

Double check that with fwconsole sysadmin ports in ssh.

does http:/FQDN/index.php or http://IP/index.php work?

To be more specific, you are looking for the port entries for services labeled acp (http) or sslacp (https) in the output of fwconsole sysadmin ports.

1 Like

fwconsole sysadmin ports | grep acp

@kierknoby Thanks for the additional hint. After running your command, I can confirm the web port is set to 80 (acp) with force https disabled. 443 (sslacp) is also showing.

@dicko Unfortunately, navigating to http://IP/index.php produces the same error.

1 Like

What happens if you run?

fwconsole ma upgradeall --force


@dobrosavljevic Bingo! That did it! Thank you so much!

I experienced the same problem while doing an annual maintenance last week! I was not too fortunate as system CLI does not even allow to type any commands initially. Only a week after I rebooted the system did the CLI allowed me to type. It was a strange issue as the phones are all still functioning normally. Not too sure where went wrong. Thankfully we had the modules backup and we reinstalled with latest Asterisk 18 and restored all modules.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.