No extension number (SOLVED)

Zaptel channel 1 is my PSTN trunk. Zaptel channel 2 is my analogue phone. The phone rings and can be used without a problem. The phone is set to extension 10.

asterisk -rvvvv reveals this, [quote]“REALCALLERIDNUM=”[/quote]
And, *65 returns nothing, which seems to be consistent with “REALCALLERIDNUM=”.

I seem to have set an extension number, but I haven’t. Should REALCALLERIDNUM in this case be 10? If so, how to I ensure this setting?


FreePBX 2.1.3

The sollution to this was to add a callerid= line in the offending FXS channel of zapata.conf.