No ethernet interface found for seeding global EID. You will have to set it manually

Hello

I have installed Free PBX 13 on a Centos 6 (64bit) OpenVZ VPS using the instructions from your Wiki.

Skipped the Compile and install DAHDI and LibPRI part since this is a VPS and your instructions say it’s only required for hardware which a VPS does not have.

Somewhere at the end of the installation I have seen the following error:

(got: No ethernet interface
found for seeding global EID. You will have to set it manually.). Please
report this.

Installation finished OK anyway.

I can access the Free PBX Admin page in the web browser. Admin user was created, some additional modules installed and 2 test extensions created. There are no errors on the info page.

However when I try to connect to the extensions with Sipdroid on my smartphone it would show a red button (timeout, connection error). Same for an inbound trunk from my sip number provider.

All the rest on the VPS works fine, SSH, Apache, Postfix, MYSQL etc.
Firewall cannot be the issue either, because I allowed my fixed home IP.

I am under the impression that Free PBX does not know how to connect to the world outside.

Could someone please tell me how I can fix this? Some hint on where to set it manually would be helpful.

Thanks
Richard

make sure you have a NIC named eth0 is my only tip. I dont know where to change that part in the settings.

from bash

ip addr

will be informational.

Thanks for your suggestions. Unfortunatly, this OpenVZ VPS does not have
etho, network interface is venet0:0.

ip addr returns:

[[email protected] ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: venet0: <BROADCAST,POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
link/void
inet 127.0.0.1/32 scope host venet0
inet 185.185.41.145/32 brd 185.185.41.145 scope global venet0:0
inet6 2a0b:7080:10::1:3b64/128 scope global
valid_lft forever preferred_lft forever
3: gre0: mtu 1476 qdisc noop state DOWN
link/gre 0.0.0.0 brd 0.0.0.0
4: gretap0: <BROADCAST,MULTICAST> mtu 1476 qdisc noop state DOWN qlen 1000
link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
5: ip6tnl0: mtu 1460 qdisc noop state DOWN
link/tunnel6 :: brd ::
[[email protected] ~]#

IPV6 is disabled.

did you as suggested “report this”?

In the interim, perhsps edit your udev permenant rule

I know when I tried installing freepbx on one of my OpenVZ VPS servers I ran into the same issue, and I would get it to rename but would lose all internet on the reboot and never solved the issue just went and installed it from iso on another provider I had for my storage server.

Strange thing about this is that I have installed Webmin after the FreePBX installation and all what it provides works, nameserver, webserver, mysql, postfix etc. I can see the databases created by FreePBX, webserver responds, mail is being picked up etc.

Seems to be an asterisk/FreePBX problem only. Where would I report it, if not here?

Also, I have done the same install without problems couple of years ago, on an OpenVZ. Only difference between these two systems is that the working system is a FreePBX 12 and it was on a Centos 6 (32bit).

The issue is the automated installer is looking for a network adapter named “eth0” to attach to.

If you do not have one named eth0, you will need to figure out how to change it to eth0 or find where in the config you can change it.

As stated , you would need to do that in udev and reboot before anything that expects eth0 to be there would work.

likely something like

sed -i ‘s/venet0/eth0/’ /etc/udev/rules.d/70-persistent-net.rules

That way , the kernel still sees the venet0 interface but the os will refer to it as eth0

EDIT . . .

You would then of course need to adjust your

/etc/sysconfig/network-scripts/ifcfg-*

scripts to concur with the new name. Perhaps easiest to just

cp /etc/sysconfig/network-scripts/ifcfg-vnet0 /etc/sysconfig/network-scripts/ifcfg-eth0

but check to make sure.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.