No calling inbound or outbound

Some type of module update failure seems to have hosed inbound and outbound calling on my FreePBX System. I had to remove endpoint manager and Phone Applications. Neither of which I use anyhow. Now according to freepbx dashboard all systems are green for launch. However I receive a busy signal when making any kind of call to VM, Outbound, etc… and anyone calling in receives a busy signal also.

The error showing in CLI

freepbxCLI> module unload chan_rtp
Unloaded chan_rtp
== Unregistered channel type ‘MulticastRTP’
== Unregistered channel type ‘UnicastRTP’
CLI> module load chan_rtp
Loaded chan_rtp
== Registered channel type ‘MulticastRTP’ (Multicast RTP Paging Channel Driver)
== Registered channel type ‘UnicastRTP’ (Unicast RTP Media Channel Driver)
Loaded => (RTP Media Channel)

Then when attempting a call
[2018-05-28 22:16:42] ERROR[3124][C-00000005]: rtp_engine.c:447 ast_rtp_instance_new: No RTP engine was found. Do you have one loaded?
[2018-05-28 22:16:42] NOTICE[3124][C-00000005]: chan_sip.c:26419 handle_request_invite: Failed to authenticate device “200” sip:[email protected];tag=001d70fc8ef64d3d122388a0-301761c8

You removed module admin?

Anyways go to advanced settings. Search for channel driver and set it to both.

Save. Reload. Restart.

This is a known issue with Asterisk 15.4, and there is a ticket open to track it - See

Digium have changed Asterisk so it now requires PJSIP to be enabled, but, that’s not something we can just do by default. I’d actually missed this ticket, and luckily @tm1000 pointed it out to me.

Edit slightly later: I’ve done a super-quick patch to at least warn people about this - with zero testing. If anyone feels game, feel free to apply this to their ‘core’ module. No promises! 8)

Sorry that should have read endpoint manager.

I have pjsip disabled and just run chansip

As @tm1000 said, you need to enable pjsip.

I’ve enabled PJSIP again however even though I’ve changed the port on the SEP configure files for my Cisco 9971 phones the phones seem to still be trying to register on 5060 which is PJSIP. So should I change the port PJSIP works on or is there a way to get the 9971s working on 5160 correctly?

I’m getting

[2018-05-30 17:18:07] WARNING[79804]: res_pjsip_registrar.c:979 registrar_on_rx_request: Endpoint ‘anonymous’ has no configured AORs
[2018-05-30 17:18:07] WARNING[79804]: res_pjsip_registrar.c:979 registrar_on_rx_request: Endpoint ‘anonymous’ has no configured AORs
[2018-05-30 17:18:07] WARNING[79804]: res_pjsip_registrar.c:979 registrar_on_rx_request: Endpoint ‘anonymous’ has no configured AORs
[2018-05-30 17:18:07] WARNING[79804]: res_pjsip_registrar.c:979 registrar_on_rx_request: Endpoint ‘anonymous’ has no configured AORs

Over and over and over

I’m not familiar with that phone, but try putting :5160 after the server name or address.
For example:


Um, I tried in good faith to help. If you need further help, you might start by explaining what went wrong with my suggestion (phone did not accept the format, change accepted but phone still trying to register to port 5060, phone is registering to port 5160 but now there is a new error, etc.)

1 Like

It didn’t change anything unfortunately. The SEP Config files have fields for the port that SIP is on which has it as 5060 and 5061 by default. I tried changing those fields and tried changing it as you suggested but had no change. Phones still don’t register.

So it seems the phones still are trying on 5060 which is PJSIP and nothing so far I’ve done has been able to change what port the Cisco phones connect over.

            <timeZone>Eastern Standard/Daylight Time</timeZone>
                <member priority="0">
            <backupProxy />
            <emergencyProxy />
            <emergencyProxyPort />
            <outboundProxy />
            <outboundProxyPort />
        <phoneLabel>C47 Brands</phoneLabel>
            <line button="1">
                <featureLabel>Edrick Smith</featureLabel>
        <softKeyFile />
        <phonePassword />
        <loadServer />
        <uid />
        <name />
        <uid />
    <authenticationURL />
    <directoryURL />
    <servicesURL />
    <idleURL />
    <informationURL />
    <messagesURL />
    <proxyServerURL />
    <certHash />

Also of note and I don’t think I mentioned this but calling in and out works again over PJSIP so the RTP driver issue is gone. Now the question has developed into how do I get my Cisco 9971s working again with chan_sip on the new port?

Also perhaps I need to make sure the chan_sip driver is loaded again? I changed the FreePBX configuration to use both drivers again.

Well good news and I’m not sure why I didn’t do it before. But PJSIP driver works with the 9971 so I just remade the extensions as a PJSIP

Sorry that I gave bad advice. I’m glad to hear that you got it working on your own.

For future readers of this thread:

I believe that the original problem (with chan_sip) is that newer firmware on Cisco phones does SIP over TCP only. And, on current FreePBX distributions, chan_sip has TCP disabled by default. You can enable it in Settings -> SIP Settings ->Chan SIP Settings ->Enable TCP. OTOH, pjsip has TCP enabled by default, so it worked as soon as you switched. See .

In my case chan_sip and the extension were enabled to use TCP as that was how chan_sip was working before with the 9971 I had to enable TCP. Although that’s not to say that something didn’t get borked when I re-enabled PJSIP and that it could have been related to the TCP setting. But the good news is that all the 9971s have been working with PJSIP since yesterday now

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.