No caller id on DAHDI FXS


(Comoros) #1

Hi,
I’m having a problem with caller id being displayed on analogue phones connected to a TDM 410.
The card is working fine - FXO gets calls correctly and routes to softphones with caller id but the analogue phone on the FXS port doesnt see the caller id. This is also the case where an internal extension calls the FXS port.

I havent attached all the config files because apart from this the system is fine but I’m wondering if I should be adding some parameters to the FXS side of dahdi config - there is pretty much nothing configured there at present that wasnt autogenerated by the config utility.
This is a UK installation and on the FXO side I have ukcallerid=yes, cidsignalling=v23 and cidstart=polarity which I also added to the FXS side but with no luck.
Any ideas anyone?
Thanks


(Luis Felipe) #2

Are you sure there is a ukcallerid setting? I’ve only known the setting usecallerid=yes.

From Asterisk™: The Definitive Guide:

In the case of the UK, the delivery of caller ID information is signaled by a polarity reversal on the telephone line (in other words, the A and B legs of the pair of telephone wires are temporarily switched over), and the actual caller ID information is delivered in a format known as V.23 (frequency shift keying, or FSK). So, the entries in chan_dahdi.conf to receive UK-style caller ID on any FXO interfaces will look like this:

cidstart=polarity ; the delivery of caller ID will be
; signaled by a polarity reversal
cidsignalling=v23 ; the delivery of the called ID information
; will be in V23 format

Of course, you may also need to send caller ID using the same local signaling information to any analog phones that are connected to FXS interfaces, and one more entry may be needed as in some locations the caller ID information is sent after a specified number of rings. If this is the case, you can use this entry:

sendcalleridafter=2

Before you can make these entries, you will need to establish the details of your local caller ID system (someone from your local telco or Google could be your friend here, but there is also some good information in the sample /etc/asterisk/chan_dahdi.conf file).

Also, you could try and debug it with these inscructions.