No Call waiting by default in gui?

I am in the process of deploying [email protected] to a small business environment. I have found it meets most of my needs using FreePBX to manage Asterisk but I have one problem that I can’t seem to resolve.

What I want to do is be able to ring a phone (the phones are cisco 7960s) while the person is on the line. For whatever reason it seems like this line in the extensions_addional file is doing something to prevent call waiting and sending a call imediately to VM.

exten => 200,1,Macro(exten-vm,200,200)
exten => 200,hint,SIP/200
exten => ${VM_PREFIX}200,1,Macro(vm,200)

If I change it to this:

exten => 200,1,Dial(SIP/200)
exten => 200,n,Macro(vm,200)

It works (without any problems that I know of yet) as I would like using the above. This is a problem though because I can’t figure out any way to do this in the gui. So once I make this change I can no longer use freePBX to administer Asterisk.

Is there any way to do this through the FreePBX gui? By changing this am I breaking something else?

you need to enable call waiting for each extension. It is disabled by default and right now there is no setting when creating the extension to enable it by default. Once the module is installed you can set the code to enable/disable it from the Feature Codes menu, *70/*71 by default. This gives more control to the user though, in case they don’t want other calls coming in on the other lines, they can choose to enable/disable it themselves.

p

Also note that in 2.1, there is an amportal.conf switch that enables call waiting by default on new extensions. :slight_smile:

If you’re upgrading from a previous version, you may need to add this option manually (as the amportal.conf is not rewritten).

That worked thank you!

I can not activate Call Waiting on my remote sip extension 215 by dialing *70. Immediately after I dial *70, there is a couple of seconds of silence, then I hear the regular dial tone.

When calls are executed, the log file has a line[quote] dialparties.agi: Extension 215 has call waiting disabled[/quote]

I am using TrixBox 1.2.3 with FreePBX 2.1.3 and Sipura 3000 for my remote SIP extension.

you’re Sipura device is intercepting the activation code so you are conflicting with the Sipura device. You need to have call waiting activated on the Sipura device and make sure there is not a conflict with the Sipura’s activation code and asterisk. This is a common problem. You will see on the CLI when you try activating that Asterisk never sees anything.

p