No Busy on phone busy when call is from external (ISDN)

Number 33 is on line.
Inbound route for DID 350001 is transferred to Ext 33
Call from number 567-xxx coming on ISDN line to number 350001 which is routed to 33 (busy phone), and caller does not receive busy signal instead ringing signal.

Here is log when call start…

=========================================================================
Connected to Asterisk 1.4.15 currently running on elastix (pid = 2895)
Verbosity is at least 3
– Executing [[email protected]:1] Set(“mISDN/3-u9”, “__TRANSFER_CONTEXT=custom-test_transfer|350001|1”) in new stack
– Executing [[email protected]:2] GotoIf(“mISDN/3-u9”, “0 ?cidok”) in new stack
– Executing [[email protected]:3] Set(“mISDN/3-u9”, “CALLERID(name)=567206”) in new stack
– Executing [[email protected]:4] NoOp(“mISDN/3-u9”, “CallerID is “567206” <567206>”) in new stack
– Executing [[email protected]:5] Ringing(“mISDN/3-u9”, “”) in new stack
– Executing [[email protected]:6] Goto(“mISDN/3-u9”, “from-did-direct|33|1”) in new stack
– Goto (from-did-direct,33,1)
– Executing [[email protected]:1] Macro(“mISDN/3-u9”, “exten-vm|novm|33”) in new stack
– Executing [[email protected]:1] Macro(“mISDN/3-u9”, “user-callerid”) in new stack
– Executing [[email protected]:1] NoOp(“mISDN/3-u9”, “user-callerid: 567206 567206”) in new stack
– Executing [[email protected]:2] Set(“mISDN/3-u9”, “AMPUSER=567206”) in new stack
– Executing [[email protected]:3] GotoIf(“mISDN/3-u9”, “0?report”) in new stack
– Executing [[email protected]:4] GotoIf(“mISDN/3-u9”, “0?start”) in new stack
– Executing [[email protected]:5] Set(“mISDN/3-u9”, “REALCALLERIDNUM=567206”) in new stack
– Executing [[email protected]:6] NoOp(“mISDN/3-u9”, “REALCALLERIDNUM is 567206”) in new stack
– Executing [[email protected]:7] Set(“mISDN/3-u9”, “AMPUSER=”) in new stack
– Executing [[email protected]:8] Set(“mISDN/3-u9”, “AMPUSERCIDNAME=”) in new stack
– Executing [[email protected]:9] GotoIf(“mISDN/3-u9”, “1?report”) in new stack
– Goto (macro-user-callerid,s,13)
– Executing [[email protected]:13] NoOp(“mISDN/3-u9”, “TTL: ARG1: novm”) in new stack
– Executing [[email protected]:14] GotoIf(“mISDN/3-u9”, “0?continue”) in new stack
– Executing [[email protected]:15] Set(“mISDN/3-u9”, “__TTL=64”) in new stack
– Executing [[email protected]:16] GotoIf(“mISDN/3-u9”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,23)
– Executing [[email protected]:23] NoOp(“mISDN/3-u9”, “Using CallerID “567206” <567206>”) in new stack
– Executing [[email protected]:2] Set(“mISDN/3-u9”, “FROMCONTEXT=exten-vm”) in new stack
– Executing [[email protected]:3] Set(“mISDN/3-u9”, “VMBOX=novm”) in new stack
– Executing [[email protected]:4] Set(“mISDN/3-u9”, “EXTTOCALL=33”) in new stack
– Executing [[email protected]:5] Set(“mISDN/3-u9”, “CFUEXT=”) in new stack
– Executing [[email protected]:6] Set(“mISDN/3-u9”, “CFBEXT=”) in new stack
– Executing [[email protected]:7] Set(“mISDN/3-u9”, “RT=”"") in new stack
– Executing [[email protected]:8] Macro(“mISDN/3-u9”, “record-enable|33|IN”) in new stack
– Executing [[email protected]:1] GotoIf(“mISDN/3-u9”, “0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing [[email protected]:4] AGI(“mISDN/3-u9”, “recordingcheck|20090320-001248|1237504368.4”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20090320-001248|1237504368.4: Inbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing [[email protected]:5] NoOp(“mISDN/3-u9”, “No recording needed”) in new stack
– Executing [[email protected]:9] Macro(“mISDN/3-u9”, “dial||trT|33”) in new stack
– Executing [[email protected]:1] GotoIf(“mISDN/3-u9”, “1?dial”) in new stack
– Goto (macro-dial,s,3)
– Executing [[email protected]:3] AGI(“mISDN/3-u9”, “dialparties.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
dialparties.agi: Starting New Dialparties.agi
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
dialparties.agi: Caller ID name is ‘567206’ number is '567206’
dialparties.agi: Methodology of ring is ‘none’
– dialparties.agi: Added extension 33 to extension map
– dialparties.agi: Extension 33 cf is disabled
– dialparties.agi: Extension 33 do not disturb is disabled
dialparties.agi: Extension 33 has ExtensionState: 1
– dialparties.agi: Checking CW and CFB status for extension 33
dialparties.agi: Extension 33 is not available to be called
dialparties.agi: Extension 33 has call waiting disabled
== Manager ‘admin’ logged off from 127.0.0.1
– AGI Script dialparties.agi completed, returning 0
– Executing [[email protected]:4] NoOp(“mISDN/3-u9”, “Returned from dialparties with no extensions to call and DIALSTATUS: BUSY”) in new stack
– Executing [[email protected]:10] Set(“mISDN/3-u9”, “SV_DIALSTATUS=BUSY”) in new stack
– Executing [[email protected]:11] GosubIf(“mISDN/3-u9”, “0?docfu|1”) in new stack
– Executing [[email protected]:12] GosubIf(“mISDN/3-u9”, “0?docfb|1”) in new stack
– Executing [[email protected]:13] Set(“mISDN/3-u9”, “DIALSTATUS=BUSY”) in new stack
– Executing [[email protected]:14] NoOp(“mISDN/3-u9”, “Voicemail is novm”) in new stack
– Executing [[email protected]:15] GotoIf(“mISDN/3-u9”, “1?s-BUSY|1”) in new stack
– Goto (macro-exten-vm,s-BUSY,1)
– Executing [[email protected]:1] NoOp(“mISDN/3-u9”, “Extension is reporting BUSY and not passing to Voicemail”) in new stack
– Executing [[email protected]:2] PlayTones(“mISDN/3-u9”, “busy”) in new stack
– Executing [[email protected]:3] Busy(“mISDN/3-u9”, “20”) in new stack
== Spawn extension (macro-exten-vm, s-BUSY, 3) exited non-zero on ‘mISDN/3-u9’ in macro ‘exten-vm’
== Spawn extension (macro-exten-vm, s-BUSY, 3) exited non-zero on 'mISDN/3-u9’
elastix*CLI>

update your version of asterisk to start. you are using 1.4.15, latest is 1.4.23.2 if memory serves me correctly. Going to that new of a version will be expecting to use Dadhi instead of zaptel. If you don’t want to go down that road at least update to the latest 1.4.21.x version as that was the last version using Zaptel drivers.

At issue is running a older veriosn of asterisk where hundreds and hundreds of bugs have been reported, addressed and fixed between your version and now.

This error is a asterisk issue not a FreePBX issue.

Well it quickly looks like the mISDN stack is not operating properly as the 4th line from the bottom say’s to play the busy tone, and the 3rd line from the bottom is reporting to the line a busy status back to the stack.

What can do to see where is problem ? Any suggestion to test ?