No audio with remote endoint when calling internal extensions, but works when calling outside line


(Nick) #1

The remote extensions were fully working a while ago, but at some point they started to have this issue, the two remote users took quite a while to report the issue so we don’t know when exactly it started to happen thus what might have changed. Remote extensions are a Mitel 6865i and a Aastra 6731i; I’ve tried it on multiple internet connections (all AT&T with plenty of bandwidth) and all extras/helpers in the home router turned off, but same issues. FreePBX is running in ESXi with a SonicWall in front. I’ve attached screenshots of relevant settings and below is the behavior of the remote phones:

Remote > External: Two Way Audio
Remote > Internal: No Audio
Internal > Remote: Voicemail (remote phone doesn’t ring)
External > Remote: Untested

I’ve tried everything I could think of and quite a few search result suggestions, any thoughts would be appreciated…

Since apparently as a newbie I can only post one image and can’t post links, here is a link to the images:
files.starbase7(dot)net/pbx/


(Dave Burgess) #2

This is your absolute first start location. Once you have all of that working, you’re good to go.

OK - One by one:

This is normal, sort of. A lot depends on where you ESXI host is. If it’s in your local network, the NAT wouldn’t be an issue for the extensions.

Off-hand, this sounds like “probably” a NAT issue with your remote phones. Without a SIP DEBUG, you’re going to have problems troubleshooting this one.

This means the Remote phone is not registered when the call occurs. That sounds like a SonicWALL problem, but once again, the NAT settings will need to be looked at.

All of this could be the SonicWALL, but I suspect you’ve got a couple of issues that working together to thwart your enjoyment of life.


(Nick) #3

Thanks Dave, one NAT rule was missing (firewalled subnets to servers public address, but shouldn’t have affected it), so I dumped the rules and recreated from the wizard and using the above linked SonicWall info. Still no luck with audio issue. The ESXi host (and virtual PBX) is on an internal LAN and the SonicWall NATs to the public address that remote phones connect to.

After much head banging, I managed to replicate the relevant parts of the main pbx in one of our other sites where I can mess with whatever FreePBX and SonicWall rules I need to without having to worry about disrupting voice services. Only difference (besides different IP ranges, and not bringing over all extensions, ivr’s etc) is I had to shift SIP to 5061 (but still UDP, not TLS) since ATT blocks 5060 at that site.

I was able to replicate the issue there and links to debug logs are below (console: “asterisk -rvvvvv” followed by “sip set debug on” and “rtp set debug on” for anyone reading this in the future).
Remote Phone to External Number (works):
https://files.starbase7.net/pbx/debug-remote-external.txt
Remote Phone to Internal Extension (no audio):
https://files.starbase7.net/pbx/debug-remote-internal.txt

From debug-remote-internal (I believe this is the issue):

Channel PJSIP/2270-00000005 joined ‘simple_bridge’ basic-bridge <24f4527d-8f4f-4770-b4d5-d17d609f97a5>
Channel PJSIP/2249-00000004 joined ‘simple_bridge’ basic-bridge <24f4527d-8f4f-4770-b4d5-d17d609f97a5>
Bridge 24f4527d-8f4f-4770-b4d5-d17d609f97a5: switching from simple_bridge technology to native_rtp
Remotely bridged ‘PJSIP/2249-00000004’ and ‘PJSIP/2270-00000005’ - media will flow directly between them

debug-remote-external stays on simple_bridge, so now to figure out how to prevent switching to native_rtp when calling internal. I already have in place in pjsip.endpoint_custom_post.conf:

[2249](+)
direct_media=no
[2270](+)
direct_media=no

Capture

Am I barking up the right tree?


(Dave Burgess) #4

@Stewart1 (I think) and/or @dicko helped another guy out with a problem that looks a lot like this. [SOLVED] How to disable directmedia in all pjsip endpoints looks like one of the prime suspects.


(Nick) #5

Thanks, I had run across that article in my searching also, but it looks like his solution was the addition of direct_media in the pjsip config files, which I already have in place. Any other thoughts?

Anyone else have any thoughts?


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.