No audio with NAT'ed FreePBX and remote, NAT'ed TLS endpoint

I had posted regarding a FreePBX machine behind NAT having trouble sending audio to a remote, NAT’ed TLS endpoint. The issue was a bug in Asterisk >=13.15. Downgrading to 13.14.1 resolved the issue. Below are captures of the symptoms:

Non-working (Asterisk 13.16):
Working (Asterisk 13.14.1):

To downgrade, run yum --showduplicates list asterisk13, find the appropriate 13.14 version, and run yum downgrade asterisk*13.14.1-1.shmz65.1.157, for instance. (replacing yours with whatever fits, if different).

Is there an Asterisk ticket for this?

edit - @jessy5765 and I hav been chasing the same bug for a few days. This is also an issue for non-TLS remote endpoints and downgrading asterisk fixes for me too. Thanks @cullenl!

I can confirm this worked. Downgrading to that version of asterisk worked. What happens now? Do we open a ticket with Digium to take a look?

@jessy5765 @lgaetz file referred me to the linked ticket. Don’t reckon you need another one.

1 Like

So if .17 is coming out today this should be fixed then once its adopted into FreePBX?

13.17 is still a release candidate, it will make it to the Distro some time after it is stable.