no audio when creating outgoing calls

integrated HT813 with Freepbx, i can send the call , i can see its ringing , but no audio at all from the both ends

from logs i can see this :
24735[2023-07-22 19:48:43] VERBOSE[26199][C-00000009] pbx.c: Executing [s@sub-send-obroute-email:2] NoOp(“PJSIP/12345-0000000c”, “email notifications disabled…exiting.”) in new stack
24736[2023-07-22 19:48:43] VERBOSE[26199][C-00000009] pbx.c: Executing [s@sub-send-obroute-email:3] Return(“PJSIP/12345-0000000c”, “”) in new stack
24737[2023-07-22 19:48:43] VERBOSE[26199][C-00000009] app_stack.c: Spawn extension (from-trunk, , 1) exited non-zero on ‘PJSIP/12345-0000000c’
24738[2023-07-22 19:48:43] VERBOSE[26199][C-00000009] app_stack.c: PJSIP/12345-0000000c Internal Gosub(sub-send-obroute-email,s,1(0790128201,0790128201,1,1690055313,96264002383)) complete GOSUB_RETVAL=
24739[2023-07-22 19:48:43] WARNING[17164] res_format_attr_siren7.c: Got Siren7 offer at 24000 bps, but only 32000 bps supported; ignoring.
24740[2023-07-22 19:48:43] WARNING[17164] res_format_attr_siren14.c: Got siren14 offer at 32000 bps, but only 48000 bps supported; ignoring.
24741[2023-07-22 19:48:43] VERBOSE[26230][C-00000009] bridge_channel.c: Channel PJSIP/12345-0000000c joined ‘simple_bridge’ basic-bridge <8e735ae3-563d-4482-925d-2e7ad95201d9>
24742[2023-07-22 19:48:43] VERBOSE[26199][C-00000009] bridge_channel.c: Channel PJSIP/103-0000000b joined ‘simple_bridge’ basic-bridge <8e735ae3-563d-4482-925d-2e7ad95201d9>
24743[2023-07-22 19:49:13] NOTICE[10316] res_pjsip_sdp_rtp.c: Disconnecting channel ‘PJSIP/103-0000000b’ for lack of audio RTP activity in 40 seconds
24744[2023-07-22 19:49:13] VERBOSE[26199][C-00000009] bridge_channel.c: Channel PJSIP/103-0000000b left ‘simple_bridge’ basic-bridge <8e735ae3-563d-4482-925d-2e7ad95201d9>
24745[2023-07-22 19:49:13] VERBOSE[26230][C-00000009] bridge_channel.c: Channel PJSIP/12345-0000000c left ‘simple_bridge’ basic-bridge <8e735ae3-563d-4482-925d-2e7ad95201d9>

yjou should allways offer and accept g711 at the very least.

appreciate your response , i managed to have audio now , but it has some echo noise , which make that not clear at all

That has always been a problem with analog lines without hardware assisted echo-detection/suppression, at least make sure the line impedance is matched to your providers ‘copper pair’ and your RX/TX levels are the same as the providers.

Possibly, you don’t have an echo problem at all. If you were testing to your own mobile (or some other phone within earshot), some sound from one receiver (earpiece) may have acoustically coupled into the other transmitter (microphone), resulting in an echo effect.

Next, the echo may be related to the extension device. Make/model or app name/version? If a softphone on Windows, Mac or Linux, the may be sound leakage from speaker to mic. Confirm that calls between extensions do not have echo.

Is Asterisk transcoding? Try enabling only ulaw (a.k.a. G.711u or PCMU) and alaw for the device and extension.

Possibly, an impedance mismatch on the FXO. What country are you in? I couldn’t guess, because your server timezone seems to be UTC, and many countries have mobile numbers in the form 07XXXXXXXX. Try setting AC Termination Model to Auto-Detected, or a setting that most closely matches what’s used in your country.

You may be able to reduce or elminate the echo by reducing TX and/or RX gain. Of course, that will also reduce the volume heard by the remote party and/or you, so some experimentation may be needed.

If you still have trouble, please post: Echo heard by PBX user, remote party or both? Device used as extension? Have you tried any others? What is FXO port connected to (copper pair from CO, cable MTA, fiber ONT, etc.)? If your system also has a SIP trunk, is that free from echo?

Analog phone lines will be better understood after reading

and you will understand why intrinsically two channel RX/TX communications, mixed into a single current loop (pstn line) without perfect subtraction of the TX signal on the (non instantaneous) RX signal and the corollary subtraction of RX from TX will be the cause of echo, clever FFT filters can ‘tail out’ echo, cheap ATA’s aren’t generally so endowed. So your best effort is to match the transmission lines’ impedance and balance your TX/RX levels as best as you can.

appreciate your help. yup tried another application as windows softphone is working now.

so i had microsip , and now using zoiper , the voice is good after adjusting gain as you proposes.

the issue with zoiper that free version can allow only one sip account while i have 4 accounts , do you know free windows softphone can work great with no issue

i see, i bought this one to be perfect option , as it was not cheap, can you recommend any , is Linksys 3102 can achieve better results

I have generally had better results with grandstream devices, but no longer have any copper pair analog services. Best results have used Digium hardware with added HWEC, but that was a long time ago :wink:

My understanding is that adaptive FIR filters are used, not FFT based ones.

Please explain why you want / how you would use more than one account on your softphone.

Both would work depending on how you look at it, but FIR usually uses lots of FFTs to accomplish it’s aim , it’s a math thing.

Neither the Grandstream nor the Sipura hardware have such balls.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.