No audio on phones, even local extension to local extension


(Shawn Anderson) #1

I have a new freePBX install, and I’ve hooked 2 phones to it, a Cisco SPA504G and a Yealink T42G.
Internally, I can call each extension and they ring but when I pick up there is no audio on either phone. Everything is on the same internal network.
I also added a SIP phone number.
The phones can all out and receive calls on that number, but again, no audio.
What could it be?


#2

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. Usually, the Detect Network Settings button will do that. Submit, Apply Config and then restart (not just reload) Asterisk.

If PBX is in a virtual machine, confirm that bridged networking is selected.

If you still have trouble: ISP? Modem make/model? Separate router/firewall? If not installed from Distro, provide details.


(Shawn Anderson) #3

ISP: Mediacom
Modem: EERO
Separate router/firewall? NO
Installed from distro:yes.

The PBX is behind my router firewall. Would firewall affect local extension to extension calling?
FreePBX firewall is disabled because it’s no in a DMZ.


#4

In Settings -> Asterisk SIP Settings -> General SIP Settings (this has nothing to do with SIPstation), you should see in the NAT Settings section, External Address and Local Networks. Confirm that these are correctly set. If you change them, after Submit and Apply Config you must restart Asterisk.

If you still have trouble, at the Asterisk command prompt (not a shell prompt), type
pjsip set logger on
if your extensions are pjsip, or
sip set debug on
for chan_sip. Make a (no audio) test call between extensions, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here. If the forum won’t let you post a link, post the eight hex characters at the end of the URL.


(Shawn Anderson) #5

the external address shows as 104.145.12.182. I assume that is correct?
The local Networks fields are blank.
What is it looking for in there?


#6

Nope, that’s the default when it ships.

Definitely wrong. Should show your LAN subnet (and sometimes other entries are needed).

Try pressing Detect Network Settings. If the results look reasonable, press Submit, Apply Config, then restart Asterisk and test.


(Shawn Anderson) #7

“Detect network settings” looks like it correctly filled in my public ip for external and my local subnet.
I still have no audio though when one extension calls the other, or for outside calls.


#8

Confirm that you restarted Asterisk.

Paste log as described earlier and post link.


(Shawn Anderson) #9

I restarted (sorry I missed that before) using fwconsole restart and it works!
Thanks so much for your help, I can’t tell you how much I appreciate it.
This is my first FreePBX installation and I learned a lot.