No Audio In/Out Calls


#1

Hi,

I am using FreePBX 15. Hosted on AWS - no router or port-forwarding. Using zoiper phone from Lan. I believe I’ve identified the problem in the attached sip-trace. My NAT external address is x.x.x.38 however, the Contact-Header is using x.x.x.63 (old/previous ip).

Where is that coming from?
Thanks!

https://pastebin.freepbx.org/view/8b885673


#2

In Asterisk SIP Settings, set External Address to xx.xx.xx.38, Submit, Apply Config, then restart (not just reload) Asterisk. If you have already done that, check that you haven’t used the .63 address in the pjsip settings. If you still have trouble, search the .conf files in /etc/asterisk for the .63 address.


(Dave Burgess) #3

It can’t be both. If you are using AWS you are most certainly using NAT and should be port forwarding.


(TheWebMachine Networks (Sangoma Software Development Partner)) #4

AWS doesn’t employ “port forwarding,” instead it’s setup like a one-to-one straight NAT; Internal IP <-> External IP, but you do need to ensure both the External Address and Internal Networks are properly configured in Asterisk SIP Settings or it will have issues resolving (you can’t just set the External Address alone). The Internal Network is the VPC CIDR (and a VPN CIDR if using endpoint VPN) and can be autodetected with the Detect Network Settings button in most cases.

Chan_SIP tab also needs NAT = Yes.

We’ve found that you do usually need to also manually specify the External Address (but not the Local Network) on the Chan_PJSIP tab.

(@Anointedone, if you are using the AWS FreePBX AMI from TheWebMachine Networks, please feel free to reach out to us directly for support via our site. We provide one-on-one chat/email support as part of your subscription.)


(system) closed #5

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.