No access to FreePBX-GUI (unequal network because of virtual machine?)

Hi
I installed FreePBX on a virtual machine (VM). Now when I enter the specified IP address in a browser on the host, the GUI doesn’t report. I suspect the problem is the different networks: IP FreePBX in the VM, i.e. guest: 10.0.2.15, IP host of the VM, i.e. router: 192.168.1.1. Do I have to use a browser in the FreePBX-CLI (guest)? If yes, how do I start a graphical browser there? Or do I have to adjust the networks? How?
Many Thanks.
Kind regards
Louis

Hi @Louis1965
I think your FreePBX Firewall blocking your LAN ip address. OR between your VMware ip address to LAN, you had some network NAT / Bridge connections issue. You have to start digging.
Below you can find some FreePBX CLI Firewall commands.
https://wiki.freepbx.org/display/FPG/Firewall+Command+Line

Thanks.

Shahin

Thanks for the tip. However, my PBX firewall is not enabled. Message after attempting to deactivate: “Firewall is not activated. Cannot be deactivated”.
Kind regards
Louis

Set in your (VM) network settings to bridge adapter mode.

Perfect. You are my hero! Now the GUI reports and I’m looking forward to the next puzzle. :slight_smile:
Thanks also to the others in this thread.
Best regards
Louis

I suspect why it works. The network bridge causes the VM to get an IP of the same network as the host. Other settings may result in the VM being on a different network.

As default network configuration is set to Network Address Translation (as router) preventing accessing from LAN to system inside.