Newbie Help Please

Hi All,

I have a pretty simple question. I have installed freepbx on my raspberry pi and have updated everything. However the issue I am now facing is that the tftpboot DOES NOT see my mac address of my aastra 6731i phone. how the heck do i get this to see my phone?
I am not a strong linux person so I am learning as i go.

Thanks for the help in advance

tftp is a layer 3 protocol, it works with IP so MAC addresses don’t really matter.

Can you expand on your question?

Okay, so I have installed asterisk on the PI and have full updated it too asterisk 11.3.0 I have set my trunk as:
; allow=g729 ; uncomment if you purchased g.729 from Digium
(pulled from website)
I’m with for my did number, when i try to dial out when i have my aastra phone set up to my extension i have created for it, it doesn’t dial out? However i know from other systems i’ve looked over there is always a .cfg file linked to your mac address of your phone. could this be the reason as to why?

The Mac.cfg file to which you refer is the configuration file for the phone. It is commonly generated by the end point manager, or it can be generated manually. You can even do without the Mac.cfg file by hoping to the phone’s internal web page and configuring it there. The phone must be configured with much the same information you used when you created the extension along with the address of the server.

If you’re using the Mac.cfg file, you’ll have to set DHCP option 66 to point to the tftp server. If this cant be done, you’ll have to go into the phone and manually enter the IP of the tftp server.

oh okay makes senses now! sorry another newbie question, is there anything in asterisk i need to change? from when i was looking up trunk settings for they were referring to adding lines into the sip.conf file system?