Newbie AsteriskNow running in VMWare on a Windows 7 Host - No Audio - Where do i look next?

Using AsteriskNow running within VMWare on a Windows 7 Host

VMWare uses a bridged network adaptor

The Host Firewall has a rule allowing TCP/UDP 5038,5060-5070,10001-20000

Ifconfig reports Centos5 NIC is using LAN address

The Router Port forwarding of WAN connections

TCP/UDP 5038 –
TCP/UDP 5060-5070
UDP 10001-20000 -

Used FreePBX to change Asterisk SIP Setting
NAT Settings:
IP Configuration: Dynamic
Dynamic Host:
Refresh Rate 120
Local Networks

Everything else is default

Created Extensions using FreePBX
2 Internal Extensions and 1 External Extension

These devices use the follow typical setting.

secret somethingsnappy, dtmfmode rfc2833, canreinvite no,context from-internal, host dynamic, type friend, nat yes, port 5060, qualify yes, callgroup blank, pickupgroup blank, disallow blank, allow blank
dial SIP/6045163, accountcode blank,mailbox [email protected], deny, permit

When I test Internal SIP phones(x-lite) – they register and complete internal calls with audio and voicemail recordings.
However the External SIP softphone(x-lite) – it registers and connects inbound/outbound calls but without audio, the voicemail connect but recording fails too.

Where would i look next to trouble shoot?

It’s awful hard to troubleshoot a VMware installation as there are so many variables. VMware uses its own internal network structure to connect to the native Windows networking. You’ll want to take a look at all of the internal VMware networking and be sure all of the appropriate ports are open.

I say again…you’re asking for trouble if you’re hoping to use a VMware installation in a production system. FreePBX/Asterisk really needs to run on a dedicated system so what’s the point of running it under VMware.


Thanks for your views on production environments. [email protected] does suggest the AsteriskNow can be installed on VMware and up and running in 30ish minutes… The virtual service is a growing service pattern. Hopefully more contributors will share their own experience. All that said.

I’ve made adjustments to the Asterisk NAT settings using FreePBX GUI and held the VMWare setup unchanged.

The senario involved changing the NAT Setting IP Configuration - Dynamic IP, Static IP and Public IP.
Then test by placing a call between two external extension using sip x-lite beta 4. This call senario was designed to trigger a un-answered call and then the recipient returns the call back to the originator’s voicemail.

Public IP - The recipient received an address of the originator being [email protected] The return call failed. is the LAN IP of the AsteriskNow on the VMwareplayer.

Dynamic IP - The recipient received an address of the originator being [email protected] The return call failed.

Static IP - The recipent received an address of the originator being [email protected] The return call to voicemail was successful.

It seems that AsteriskNow favors the Static IP

Does AsteriskNow get the IP used in Dynamic IP Configure from the Hosts file?

We have a dynamic ip account connecting the AsteriskNow instance.

Should we be changing the /etc/Hosts file to reflect the current WAN address?

I’ve read an old posting about a workaround which re-writes the sip_nat.conf file to update the ‘Static IP’

Does FreePBX GUI complain about edits to sip_nat.conf when using the workaround?

Your internal test of a non natted sofphone ( or desk phone) using nat=yes may produce your issue. Try setting that local ext to nat=no.

And not for nothing, Windows 7 is not a server platform. VMWare on WIN2003/8 server is a much better choice if you insist on VM.

Also, did you try turning the WIN7 firewall completely off and test ?