New System Throwing Symfony Error

Installed a brand new shiny version of the FreePBX 64 stable distro on Vultr.com. Everything goes great until I upgrade the modules. I am getting this error:

Symfony \ Component \ Process \ Exception \ ProcessFailedException
HELP
The command “cd /var/www/html/admin/modules/pm2/node && mkdir -p /home/asterisk/.pm2 && mkdir -p logs && export HOME=”/home/asterisk" && export PM2_HOME="/home/asterisk/.pm2" && export ASTLOGDIR="/var/log/asterisk" && export ASTVARLIBDIR="/var/lib/asterisk" && export PATH="$HOME/.node/bin:$PATH" && export NODE_PATH="$HOME/.node/lib/node_modules:$NODE_PATH" && export MANPATH="$HOME/.node/share/man:$MANPATH" && /var/www/html/admin/modules/pm2/node/node_modules/pm2/bin/pm2 jlist" failed. Exit Code: 126(Invoked command cannot execute) Output: ================ Error Output: ================ sh: /var/www/html/admin/modules/pm2/node/node_modules/pm2/bin/pm2: Permission denied

I have reinstalled several times today and the same error is thrown with each new install.

Also, the UCP acts like it is working and when trying to upload an audio file to the voicemail greetings it immediately goes into offline mode. The UCP is showing as working in the dashboard.

Any ideas?

I’ve replicated the UCP error on Firefox and Internet Explorer. Could that one possibly be a permissions error?

After you install, but before you do anything else , you need to perform a yum update -y

I was able to reproduce the UCP error in both the current stable release and the RC1 so maybe a bug?

As soon as this new (#8!) instance installs I’ll try the yum update -y suggestion prior to doing anything else.

Curious as Rc1 doesn’t have an offline mode. It will be way more verbose and completely different looking

I get the exact same error in the UCP after following the yum update -y suggestion.

It did however resolve the other Symfony error.

I’m out of ideas. Any suggestions?

Edit: This was done on a fresh install from the stable freepbx.org iso file.

You couldn’t have gotten the same error between 13 and 14. It’s a completely different interface. There’s no offline mode.

The behavior was the same. I apologize; should have been clearer. No “offline mode” error was given. I added a voicemail widget and tried uploading both a wav and mp3 file. Both times the file never appeared to upload in any way. I tried on both Chrome and Firefox.

That’s not the same error at all. In one it goes offline meaning it crashed. In the other it does nothing.

I really just need some help getting the voicemail greeting uploaded manually. I’ve been at this since 8AM this morning through 8 instances trying to get this phone system working.

It’s probably a bug. Nothing more you’ll be able to do until it’s fixed. Upload the file somewhere and we can test.

I had the same problem when updated “Process Management” module to version 13.0.3.6. There is a ticket https://issues.freepbx.org/browse/FREEPBX-14629 about this, but it is closed. I fixed the issue with following commands:

cd www/html/admin/modules/pm2/node/node_modules/pm2/bin
chmod +x pm2

It is definitely a bug in this module, which should be fixed, instead of asking to execute manually, as suggested in the ticket:

fwconsole install pm2

I didn’t try if this suggestion fixes the problem.

Because it already is fixed:

We asked you to reinstall the module.

I am still having the voicemail upload issue on brand new installations of both RC1 and the stable version.

I’m going to use the stable version to build out the phone system. Any ideas on fixing the offline mode error so I can upload greetings to voicemails?

^^^^^^^^

https://drive.google.com/drive/folders/0BzjvAzHbT2iKZE9EcGFxOGVVUkE?usp=sharing

The files both work on my production server. But both fail on a freshly installed server. Could this be a permissions issue?

Any ideas Andrew?