New SIP Trunk Weird Settings

Hi All,

First time posting because for the first time in 5 years I can’t find an answer and I’m well and truly stuck!

I’ve got a new SIP trunk, I think it’s a Daisy SIP trunk in the UK, I’ve been sent a guide and a Username (Trunk Number), Auth ID, Password and domain.

I’ve followed the setup as detailed in the guide which included adding the domain to the hosts file.

The trunk shows in peers as OK, and displays on the dashboard as connected:

Name/username Host Dyn Forcerport Comedia ACL Port Status
NewTrunk/(auth id) . (ip address) Yes Yes 5060 OK (7 ms)

The Trunk Peer details are entered as per the instructions copied below with my details removed:

user=phone
type=peer
trustrpid=yes
secret=(password)
qualify=30000
outboundproxy=(outbound proxy from instructions)
insecure=invite,port
host=(domain)
fromdomain=(domain)
defaultuser=(auth id)
canreinvite=no
;;session-timers=refuse
;;sendrpid=pai
;;fromUser=(trunk number)
;;dtmfmode=inband

Register String is:

(trunk number)@( domain):(password):(auth id)@(outbound proxy from instructions)/(trunk number)

The outbound proxy from the instructions (sipt-dynamic-bslnws09 [dot] yourwhc [dot] co [dot] uk) is an SRV record, I have set ‘Enable SRV Lookup’ to yes in the chansip settings. I’ve also tried replacing this with the lowest priority target when resolving the SRV record, neither worked.

However I can’t place or receive calls, FreePBX is in a DMZ with the Sangoma firewall running the show.

chan_sip.c: – Registration for ‘(trunk number)@(outbound proxy from instructions)’ timed out, trying again (Attempt #45)

When Placing a Call:

chan_sip.c: Received response: “Forbidden” from ‘“Anonymous” <<sip: [email protected](domain)>>;tag=as0ad2db1f’

Thinking that it might be the fact that fromUser is commented out in their settings I commented that and tried it with both the trunk number as it was with the comment out and with the auth id. Each time I got the error message but with the auth id or trunk number in place of anonymous.

I tried tweaking the settings myself and managed to get what appeared to be a registration.

It’s unlike any trunk I’ve setup before, having both a trunk username, and an auth id! Has anyone seen this before or have any pointers where to go next?

Thanks in advance!

I think that would undermine a DNS SRV lookup. Why do they instruct you to do this?

A SIP trace using either Asterisk’s SIP debug output or running sngrep would probably reveal the problem.

That is a different domain, there’s the outbound-proxy address which is an SRV record. Then another domain was provided to use in the host, and fromdomain. That ‘domain’ is just companyname.hosted and doesn’t resolve publicly, the instructions said to set that an IP address they have detailed.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.