New Sangoma P330 phone not registering on pjsip

I got the new Sangoma P330 phones and trying them out by adding to an existing pbx. I had them setup as chansip since that’s what the old phones were setup as. The phones are registered in the Sangoma portal for portal redirection. They came up and registered and pulled the config and BLFs worked and they rang but I was not able to get any audio between handsets or external calls. Also I manually had set the port to 5067 and 5068 on the phones since we’re already using 5060 on another voip phone here. However the one phone still showed registered on 5060 and another on 1074 which tells me theres a port conflict.
Anyway I decided to switch to pjsip extensions. Now none of the BLF’s work and the Presence used to show Available has now disappeared. And the Line key has a ? in front of it.
EPM extension mapping shows a blank for IP address status. But I can’t log into the web gui on the phone since it’s apparently registered.
sngrep shows a bunch of register and subscribe for these extensions.
The firmware is 4.6.2 even though EPM shows the version should be 4.6.3 for 1.49
This is on an updated freepbx 15 box with Asterisk 18.9 and I just restarted it.
What’s the next step to troubleshoot why blf and calls don’t work?

I am not sure, but it could be that the P330 needs a certificate and a https connection to the phone app server.
The P370 definitely does…
It’s not trivial if you have a local phone system. You need port forwarding and a DNS entry which points to the local IP of your freePBX server.

EDIT: Did you try a new netscan in EPM?
Extension settings: udp is fine, port should be same as in Asterisk SIP settings.

It did cross my mind that that could be the problem, but I didn’t see any documentation on it being a requirement. It’s a cloudhosted pbx so I setup a subdomain for it and am waiting for the dns to propagate. Netscan won’t work since the pbx is not on premise. I’ve never used netscan, I’ll have to try it for local phones.

I setup a LE cert and reset the phone with no change. Then I added a firewall rule to allow incoming traffic to the phones reset the phone and it came up! On the 2nd phone I hit the logout button and it said please waiting, restarting phone to update configuration. And hung on that screen for 20 minutes at least, so I restarted it. Now it wants me to login. I reset the password in User management for that extension and tried that password but it just says Please fix the following errors Error code -2 unknown error
How do I reset the phone now? Only options are the Login screen, Delete and Help. And nothing happens when I hit help.

Did you set a different port for the second phone? If yes, that’s wrong. All phones connect to the same sip port. Check your udp port in Asterisk SIP settings or just use the same settings of phone one. Reconfigure und reload phones through EPM.

EDIT: If you set a password for provisioning in freePBX, then you might have to enter this password on the phone.

1 Like

No, there are both on 5060
There is no Global Pin set in DPMA