NEW S300/S500 Drop Registration

I am a first time FreePBX/Sangoma Phone user. I have a S300, S500 running FreePBX 14 (distro) fully patched. I initially was able to register the phones via No Touch Provisioning using RS site. However, I discovered the S500 did not upgrade firmware and wouldn’t apply some of the template settings. I later found the phone was showing offline on dashboard although it was still on. I decided to reset to factory and reregister; bad idea. Phone would not register regardless of what I tried (chan_sip/pjsip/tftp/http). So then I manually upgraded the firmware to the latest release as of 11/25/2017; still no joy. I’ve wiped out all extensions, users and templates to start off somewhat fresh; no joy. When the phones initialize the display is only showing retrieving information from RS portal URLs and not my server.

The S300 later started displaying the same problem of no longer taking/accepting template configuration changes; so I’ve also reset it. Now behaving the exact same why as the S500 and will not register/provision.

Last night, I notice something odd after resetting the phone to factory (multiple times) the phone time was exactly 6 hours off; even after setting to my time zone in web gui. I noticed the same in the portal during polling intervals. All these headaches got me wondering, are the phones shipped with a different initial config than when they are reset?

I’ve read others have experienced the exact same issue(s). Also, while searching for solution I’ve seen some state the HTTP Provisioning port is 83, but my server says it’s port 84; did this change at some point and time? Anyone have suggestion.

And another thing: Why is my phones configured to send syslog information to this address after resetting to factory?

I’ve been monitoring the logs of the server while attempting a zero touch provision of the phones. They ARE NOT communicating with my server at all.

UPDATE: So as of my writing this, 57 views. I’m very surprised no one had any feedback. But never the less, I’ve resolved the issue myself by reinstalling server; this time with FreePBX 13 distro. And, I think I know what happen. While looking through some of the new settings after my purchase of the SysAdmin Pro module, I noticed the Network Setting page showed server address was DHCP (button highlighted). So I selected the Static/Manual button (I don’t recall) without any change of the address. This through a firewall error on the dashboard. I ensured all firewall settings were correct, even with a confirmed save and rebooted the server. Firewall error was cleared. I think this somehow hosed phones ability to communicate with server. Although, the S500 did not fully apply the template from the start.

Speaking of which, even know I’m still seeing little weird anomalies with the applying of templates; but much better than before. And I know my case isn’t unique, as I’ve read several posts of others seeing similar symptoms. BTW…the issue with how SysAdmin displays an already statically assigned IP address with the DHCP button highlighted should probably be corrected.