New PIAF system, noob needs help

I just received a pre-built server and it arrived with zero documentation. I know very little about Linux, and this is my first experience with Asterisk. I did manage to wrangle the root password out of the distributor, but the company that built the system is unavailable for support until Jan 8.

On connecting it to our network and turning the system on, I get the following info:

PBX in a Flash Purple Status Program

PIAF Installed Version = under HARDWARE
Free PBX Version =
Running Asterisk Version =
Asterisk Source Version =
Dahdi Source Version =
Libpri Source Version = 1.4.14
IP Address = on eth0
Operating System = CentOS release 6.4 (Final) <>
Kernel Version = 2.6.23-358.6.2.el6.x86_64 - 64 Bit

I have tried connecting directly to the IP from another PC on the same subnet, but without success. I cannot Ping the IP address.

I have no idea what to do next. Any help will be greatly appreciated.

Save yourself some time, and frustration, just follow these steps to install the FreePBX Distro. ( ) Starting over would be the best action I could recommend, as you don’t know exactly how they installed PIAF, installing the FreePBX Distro should only take about 15 minutes or so following the instructions listed above.

Was the IP address you mention acquired by the machine via DHCP, or was it already statically configured in the machine?

When “connecting directly to the IP”, what port(s) and protocol(s) did you try?

Did you check the iptables configuration to see if it’s blocking something?

The third question above is Linux-specific. The first two are not.

Thanks, skybus for your response. The IP address was obtained from the DHCP server. I used http to connect to the IP. I have no clue how to check iptable configuration.

I’m not sure how I did it (I don’t think I tried anything different than what I was doing before), but I got the browser to connect to the asterisk server’s IP. Maybe it just took a while for my Windows8 PC to get comfortable with the idea of talking to a Linux PC.

I got into the PIAF browser interface, and now I am overwhelmed by hundreds of menu choices and options I have no idea how to configure. I’m off to do some light reading…

Thanks for your time. I may be back as soon as I think of some semi-intelligent questions to ask.

OK, whatever I did (or whatever fortuitously happened) to allow me to connect to my asterisk server was only temporary.

Using the linux netstat command, I learned that the IP address showing up in the PIAF status window is assigned to a UDP port. All 4 of my TCP ports are showing I’m not sure where to go from here. Any help will be greatly appreciated. (I know very little linux, so if I need to provide more details, you may have to give me a little help in how to find the information you need to assist me.)

If they have installed incredible PBX on that installation it would have locked down iptables, if you have ssh access issue the command “service iptables stop” and see if that helps. Also please note if you were connecting before and cannot now, it is possible that you have fail2banned yourself by entering a wrong password too many times. “service fail2ban restart” or rebooting should clear that… but like in my first response I would strongly recommend re-installation from scratch, as you don’t know what settings were configured, or modifications may have been made by the original installer.

Stopping iptables and restarting fail2ban did not help. The guy who configured the system is back at work Monday, so I’m not going to try re-installation. Re-installing may seem a trivial thing to you, but it intimidates me and I’d rather wait than spend my weekend wrestling with an unfamiliar system.