New instance, PJSIP just a nightmare

Hi there.
I have to setup a new FreePBX for my company, not my first one, but as the new version FreePBX 16.0.10.34 tend to go only to PJSIP, I want to try it.
Unfortunately - a nightmare.
I had no issue to setup my provider Trunk, and I was able to test this today properly.
Unfortunately there is some apps like Bria that doesn’t work with it (no sound and hangup after 30 seconds saying no RTP traffic).and with the app that works, it doesn’t hang up when I hang up, cutting the line more than 30 seconds after.
With Bria, I have this in the Log (echo test doesn’t work, with the other app it works the echo but hangs up 30 seconds later than it should):
[2021-11-08 15:18:43] NOTICE[2730] res_pjsip_sdp_rtp.c: Disconnecting channel ‘PJSIP/101-00000006’ for lack of audio RTP activity in 30 seconds

I tried and check my router and firewall settings but I don’t see anything that blocks any traffic, so I’m a bit lost.
RTP Symmetric and Force rport are set to Yes in the extension.
Also the server has a Public IP with no other Firewall.
I’ve tried to turn off the FreePBX firewall but it’s the same issue.

Thanks

Make sure you have the correct network definitions (external IP, local nets) in Asterisk SIP Settings.

The “Detect Network Settings” button should fill in the fields automatically.

1 Like

mmm interesting, it looks like it accepts the IP but not anymore a FQDN?
But shame, I should have tested this already.

this reads EXACTLY as the SIP "Contact: " header is using your internal / LAN IP and not one of your routable WAN IP addresses.
both the “RTP 1 way audio” and the “call dies at 30 seconds”… as well as the “hangup doesn’t hang up” means the traffic isn’t actually getting to the other end.
Which is usually the Contact Header
which is the Externip on your trunk (likely)

on a PJSIP trunk, take a look at PJSIP Settings > advanced > Media Address.
set that to your WAN IP.