New installation issues on ArchLinux

Hi guys,

I want to install freepbx on archlinux with asterisk1.8… I installed asterisk and freepbx, went to mysql - made the dbs and granted permissions and now I was on the final step of the freepbpx’s installation (with the user and pass for the permissions of sql):

I don’t know what’s happening… The asterisk’s installation is fresh as freepbx’s with NONE of the conf files edited… How can I manage it to work?

Also, after 1-2-3-4-5 retries, while installing asterisk I get this:

Can you help me?


Well Archlinux is not a supported OS so you are going to have to work out permissions issues. Clearly you haven’t granted sudo permissions and who knows what else.

I don’t know anything about archlinux so I have no idea what to tell you.

Is it even Redhat based?

Did you search for the term archlinux in the forums? I seem to remember someone else trying this.

I don’t know why you want to use such old version of asterisk ? asterisk 11.1 has better support for Google voice and other stuff.
You need to install sudo so type in pacman -S sudo. You need to make sure that apache runs as asterisk so edit httpd.conf and make sure you change settings to
User asterisk
Group asterisk
aur freepbx has install instruction.
You can ignore the last error you are getting.

Good morning and thanks for your response …

About the old version of asterisk, on my first try, I installed asterisk 11.x but I think when I tryied to install freepbx it wasn’t proceeding because of the asterisk 1.x need. I will try once again.


Hey, i have an update

After all I got installed the fpbx 2.10…

Now, apache does something …

When I browse http://localhost I can see the main page with the fpbx logo and options/links for Voice messages and Adminstration.

When I click one them, browser comes with en error… HTTP 500. “The website encountered an error while retrieving It may be down for maintenance or configured incorrectly.”

Thanks for you help…

You need to look at arch linux wiki on how to enable php support for apache. You will need to change php.ini per directions aur install file. You can change PKGBUILD in aur inn order to install freepbx 2.11 beta

I have enabled successfuly the PHP support (before this I just got a directory listing of /admin instead of this error)… Will install 2.11beta.

The funny thing is that it’s always updates to some alpha version when I install the 2.10 stable…


So, tryied to install the 2.11.beta1.

Of course I removed first everything from the previous installation and went again to install the new.


Well you need to edit php.ini and you need to comment out open_basedir.

open_basedir is commented… it has the ‘;’ before the option…

Did you installed php-pear ? Dud you enable modules in php.ini ? Did you execute
cd /usr/src/freepbx && ./install_amp --username=asterisk --password=password"
and then cd /usr/src/freepbx && ./install_amp

Did you installed php-pear ? Dud you enable modules in php.ini ? Did you execute
cd /usr/src/freepbx && ./install_amp --username=asterisk --password=password"
and then cd /usr/src/freepbx && ./install_amp

Yes, I enabled the modules and have php-pear.

I got to something, but now it cant connect to db…

Mysql running, privileges ok, password same.

New installation of 2.11.0beta1:

Look at ./usr/src/freepbx/ line 51: [FATAL]: command not found
find out what are you missing and install it

Changed title of thread to clarify subject and improve search hits.

Hi guys and happy 2013…

Found some time again to play with it… Trying to find the error in line #51 but… I can’t find/understand the fault.

Here’s the file…

Thanks for your help

Make sure you have /usr/src/freepbx/amp_conf/bin/gen_amp_conf.php

Removed everything with all configuration files, installed again (2.11beta1) and It was ok… but when I go to the /admin page, I get an error…

and that was the output when installing again the freepbx:

seems ok I guess…

I have the file…