New installation gets stuck

I burned the distro (32 Bit Stable-5.211.65-13, 06-03-14) to a DVD.

The installation stopps at module 425 (PBX Web Interface) - I waited for 24 hours, nothing happends.

When I used an older version (2 years old) it worked, but I need a newer one.

What should I do? I have tried 4 times.


Doesnt seem like you have stable internet. Do you? It’s most likely getting stuck at downloading all modules.

I have Fios and it is very stable. I can ping the box (physical box) with no problems. I have tried the installation 6 times now, always gets stuck at the same point.

There is no internet activity before it gets stuck.

Old versions work with no problems.

I have read here of at least 2 people with the same porblem, but I could not find a solution.

That is because we can’t duplicate it. It’s very rare and only happens to less than 1% of installs and is Internet related. Usually packet filtering or unstable Internet.

Hi all, I’m one of those two guys out there that had this issue.

Despite I was able to install (but not without troubles) at least two FreePBX Distro system since the start of June I then given up with new FreePBX Distro installs.

I’m still not sure if the issue I saw gone away, I mean: I didn’t test a new install since those days (End of May, start of June if I recall well) so I can’t speak in regarding to new ISOs released up to now.

I say “I’m still not sure” because either with my latest two FreePBX Distro installations I tried - a FreePBX 6.12.65-13 Beta for testing and a FreePBX 5.211.65-13 of June updated to -14 and then to 6.12.65-13 track for testing - I experienced on both install processes little troubles at the point that, after the first boot and every time I log into both systems, they both ask me to run firstboot script every time (but Network is really OK, trust me) because both systems believe that actual Internet Connection is (or was at install time?) bad, which is actually not…since I then updated them nicely via GUI/CLI.

My Internet Connection is not Fiber Optic (Would be fantastic! go figure!) so I’m really in the wild with a simple Asynchronous DSL line 7Mbps download link, just pretty stable…not fast at all…but reliable enough to let me download (many) ISOs withouth major issues during the day (slowest) and night (fastest).

So the question that I rise is: “How is it possible that a FreePBX Distro ISO downloads without a glitch (MD5 Sum check OK) and then the system on which I’m installing - system that’s using the same link to Internet just few minutes after the ISO download completed - sees a crappy/unreliable/faulty Internet Link while from the same subnet - other host - I’m happily browsing the Internet?”

Test were done almost consecutively (both at night and during the day, weeks ago)…FreePBX Distro 5.211/6.12 ISOs Download -> MD5 Check (OK) -> Burn DVD -> Boot DVD for Install on bare metal box -> Media Check (OB) invoked at boot -> Anconda starts then will stop at 425th package with apparent no inbound/outbount traffic to Internet (I reported it with great amount of details here).

It looks like a sort of timeout jumps in…during packages retrive from mirrors.

I mean, I should haven’t been able to just download any ISO so far…if the Internet Link was really crappy.

I started to think that latest FreePBX Distro 5/6 changed the way they retrieve packages (or the way they communicate/push to Schmooze gathered installation information - if any - during packages install) from repositories…I could be wrong…but this is just my personal feeling and I admit I haven’t a way (nor the time) to demonstrate/investigate that.

Despite I changed a rule on my Firewall (see my latest post on the linked thread) I’m not sure that that rule change resolved (or was effectively related to) the issue of the stuck install: nobody told me that the FreePBX Distro install process needs some sort of Firewall Rules configuration (to let some sort of inbound traffic goes in) other than the basic default rule that grants access from any LAN host to any External host.

Could be something related to AS or peering/routing between us (users with problems) and FreePBX mirrors/repositories? if “Yes, It could” then…and ISOs? why ISO download isn’t/wasn’t a problem at all?

What do you want me to test or debug to hunt this down?

I ran into the same issue as I didn’t expect the “offline” installation via DVD to require Internet access to complete.

After 1 hour of debugging, I believe I found the source:

It only happens if you have more than 1 NIC (network interface) available on the system where you install FreePBX.

Why this happens - I don’t know.
How to mitigate this situation:

Switch to the command shell (Ctrl+Alt+F2) when the installation is stuck at whatever package that requires Internet access and disable all the NIC not in use (usually all but eth0/lo)

ifconfig eth1 down

Repeat this for any additional NIC in the system (you can find out which others are there using):

ifconfig -a

Hope this helps …

Release Date-06-19-14
FreePBX 12, Linux 6.5


Mmmm…not sure…but I ran in the issue with AND without a second NIC (PCI card) other than the usual NIC integrated into the motherboard. Basically I always tried with just the motherboard’s NIC and few times by adding a second one thinking that the issue could be tracked down to the internal NIC. But it couldn’t.

Encountering the same problem with 64 Bit install of 6.12.65. Have tried with only one interface card enabled. Any suggestions how to resolve please?

Same problem with any Distro installation of Freepbx 12. Is there a way to resolve please?

Issue is resolved. Install took 30 minutes on one module.

I was doing an install of 64bit 6.12.65 from USB image, and it hung at 69% as well. (FreePBX Web Interface) After waiting about 15 minutes it continued along.

Same issue here: with or without 2nd ethernet connection.
Using the FreePBX-64bit-10.13.66 iso on a Proxmox KVM virtual machine. Stuck on 69% every time, the freepbx- when chosen for the HA-option in the Grub boot menu…
Also with the non-HA, no-raid and default options… always the same package where it is stuck…
in F9 I see a bunch of connection attempts and updates, last line is
"Manager registered action BridgeKick" and then in disconnects the session, console stays open on *CLI>

Any advice?

Even trying the SNG7 64bit RC1 iso, I get stuck (over an hour) at ‘Installing freepbx (570/646)’…

Tried 2 machine, same issue…

I got stuck at the same point but it suddenly took off after 30 mins. This is on a 24 CPU machine with SSD so on other hardware it’ll probably take much longer. Some progress indication would be nice though.