New install with SIP STATION

Hello,

I’m setting up a new install.

Using FreePBX 16.0.21.8

And I’m in the trial of SIP STATION (first time I use it).

I went though the setup and everything is fine except that when I receive a call, the other end doesn’t hear my voice.

This is only occurring on inbound calls.
Outbound calls are fine!

My firewall is set to forward the following ports (UDP) to FreePBX : 5060, 5061, 5160, 5161 & 10000 to 20000.

Any idea what could be causing the outgoing voice to not be sent in inbound calls?

Thank you!

Have you confirmed the ports are actually open? Specifically the 10000-20000 ports?? SIP ALG turned off???

Yes the ports are open!

What is SIP ALG?

I’m using pfSense as a firewall / gateway

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set.

If you change these, after Submit and Apply Config you must restart Asterisk.

I dont use pfsense but after a quick search it doesnt appear you have to worry about SIP ALG on pfsense…

Yes external address and local networks addresses are correctly set!

in pfSense, I followed these instructions:

https://docs.netgate.com/pfsense/en/latest/recipes/nat-voip-phones.html

and

https://docs.netgate.com/pfsense/en/latest/recipes/nat-voip-pbx.html

Still won’t work.

It states that “With a minority of providers, rewriting the source port of RTP can cause one way audio.”

I did set my RTP ports to STATIC.

I don’t understand why it still does not work

Definitely sounds like a pfsense/network configuration issue…

Usually making RTP ports static works on pfSense. I would look at a pcap (you can use sngrep on the PBX’s CLI) to see what’s the address you are sending out as your external address, also the contact information.