New install of freepbx 11.x then upgraded to FreePBX 12.0.1rc28

So, I downloaded the ISO, did a green install, and then ran the module upgrades till everything was latest version.

I configured my SIP trunk for Gamma, then then extensions, and then inbound and outbound routes.

Internal calls work fine,but outbound calls fail to connect… checking on the asterisk cli I can see the problem, which is it is not sending my external IP address in the invite and I’m getting:-

[2014-10-04 16:33:28] WARNING[1788]: chan_sip.c:4190 retrans_pkt: Hanging up call [email protected] external IP address - no reply to our critical packet (see https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions).

Now, I’ve checked the Asterisk Sip Settings and see my external IP address exactly where I left it, displayed correctly, and Local networks also show correctly.

Can someone point me at where it is picking up the “@your external IP address” and not inserting the actual IP address?

Here’s the version details:-
PIAF Installed Version = 2.0.6.5 under VMWARE |
| FreePBX Version = 12.0.1rc2 |
| Running Asterisk Version = 11.10.0 |
| Asterisk Source Version = 11.10.0 |
| Dahdi Source Version = 2.9.0 |
| Libpri Source Version = 1.4.14 |
| IP Address = 192.168.102.100 on eth0 |
| Operating System = CentOS release 6.5 (Final) |
| Kernel Version = 2.6.32-431.1.2.0.1.el6.i686 - 32 Bit

I would check your trunk’s outbound settings.

Did you also check SIP Settings > Chan sip?

Checked that it’s on
Nat - Yes,
IP Configuration - Static IP.
Even stuck the external IP in the Override External IP with the correct one

Peer and Host details both have a HOST= and the external IP address set…

For some strange reason the system crashed overnight. After a full reboot, the mystery of where it was getting “@your external IP address” is no longer an issue.

It’s just all working… now.

With the exception of it keeps telling me to update the module “versionupgrade (2.11.1rc9)” but this isn’t in the module admin…

Remove the message. You won’t see it again

Thanks… done this and vola it’s not created it again…