New help editing my sip_general_custom.conf file

I am running a Debian based Shiva appliance running PlugPBX. All my existing VoIP providers have worked fine without need to edit the sip_general_custom.conf file, however I am now testing Broadvoice and it does require I make changes to that file. Since I have never needed to do this before I am unsure how to go about it. Can anyone assist in what commands I need to run in order to make the necessary changes?

What version of FreePBX?

That version is old. While you are in the system take it to 2.9.

You can update via the FreePBX web interface.

Then you can add the setting in the sip settings module.

What parameter are you trying to add?

Ok so I just updated to 2.9. However, I dont see a SIP Settings module anywhere. I was told by Callcentric I need to add the following:


Disregard my last comment, I found the module needed and downloaded it. However, upon opening it up there is a large error stating


Settings in /etc/asterisk/sip_custom.conf may override these. Those settings should be removed."

Is it necessary to make the changes in that location, or can I simply do so from this module and disregard the error notice?

If you are using the sip settings module you should not have anything in the sip_custom.conf

Just curious, but will making the changes Callcentric requires have any negative impact on my other SIP trunks I have setup?

No, but making the default context from-pstn is about the same as allowing anonymous SIP. You can’t originate calls but any call that matches the inbound routes will be processed even if a matching peer does not exist.

Thank you for your assistance, although I am still not able to get this working. I see a few entries from Callcentric which I dont see a setting for. Below is a capture of all the possible settings from ‘SIP Settings’, any additional advice is appreciated.

NAT Settings
yes no never route
IP Configuration
Public IP Static IP Dynamic IP
External IP
Local Networks /

Audio Codecs

move ulaw
move alaw
move gsm
move png
move lpc10
move speex
move g722
move adpcm
move jpeg
move g723
move slin
move g726
move g729
move ilbc
move g726aal2 

Non-Standard g726
Yes No
T38 Pass-Through
Yes No
Video Codecs
Video Support
Enabled Disabled
MEDIA & RTP Settings
Reinvite Behavior
yes no nonat update
RTP Timers (rtptimeout) (rtpholdtimeout) (rtpkeepalive)
Notification & MWI
MWI Polling Freq
Notify Ringing
Yes No
Notify Hold
Yes No
Registration Settings
Registrations (registertimeout) (registerattempts)
Registration Times (minexpiry) (maxexpiry) (defaultexpiry) (CHANGED TO 90 for “minexpiry”, CHANGED TO 180 for “maxepiry”, not sure what to set "default expiry to?)
Jitter Buffer Settings
Jitter Buffer
Enabled Disabled
Advanced General Settings
Default Context (CHANGED TO from-pstn)
Bind Address
Bind Port
Allow SIP Guests
Yes No
SRV Lookup
Enabled Disabled (CHANGED TO ENABLED)
Call Events
Yes No

Other SIP Settings =

So you can see above in parenthesis (and caps) what I changed, but I dont see where to set “session-timers=refuse” and “session-refresher=uas”. Also, for “default expiry” I am not sure what value should be there.

I am still unable to resolve this issue. If anyone can help me figure out how to make the required edit it would be greatly appreciated! My current VoIP provider is terrible and they keep having outages, so getting this change made is critical so I can drop them and get Callcentric up and running. Any thoughts?