New FreePBX 40 - Error updating modules, many now disabled pending upgrade

Having too many modules to update I’d recommend to do it over the CLI. ‘fwconsole ma upgradeall’


That is where I am getting the errors (from the CLI upgradeall).

Should I upgrade one package at a time, if so, due to dependencies, is there a list of what order I should follow?


There seems to an issue with the Asterisk Version coming back as 0. Try doing an asterisk-version-switch and install the latest version and then yum upgrade before finally attempting module updates.

Hi Richard,

I’ll give that a go.


I do get this issue with Asterisk not being able to be stopped, is that preventing the actual upgrade to the latest version?

asterisk19 has now been verified to be installed

Checking for orphaned asterisk files in /usr/lib64/asterisk/modules…

Finished checking /usr/lib64/asterisk/modules
Restarting Asterisk…
Running FreePBX shutdown…

Running Asterisk pre from Core module
Stopping Call Transfer Monitoring Service
Stopping Core FastAGI Server
Stopped FastAGI Server
Running Asterisk pre from Iotserver module
SmartOffice Server is not running
Running Asterisk pre from Ucp module
Stopping UCP Node Server
[>---------------------------] 1 sec
Stopped UCP Node Server
Running Asterisk pre from Xmpp module
Stopping Chat Server
Stopped Chat Server
Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] 30 secs
Killing asterisk forcefully.
Asterisk is still running and we can’t stop it!

When I run yum upgrade there is nothing to update:

yum upgrade
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
No packages marked for update

My expectation is that when I try and update modules, I’ll have the same problem. Wonder if I should update modules one at a time? If so, still curious if there is an order to follow?


If there is still issues with Asterisk then it’s unlikely to matter if you do them one by one or upgradeall.

Try fwconsole chown and the fwconsole restart and see if Asterisk restarts OK?

Hi Richard,

Same issue, the system can’t stop asterisk.

Is there an option to rebuild the system from scratch that is pretty straightforward?


Press N to forcefully shut it down. if it doesn’t stop the service manually and try again.

Hi Santiago,

Pressing N doesn’t stop it and manually stopping it (fwconsole stop), also doesn’t stop it.

Next steps?


Have you tried doing a full reboot of the system?

Yes, just did so before attempting the most recent requests. Asterisk still doesn’t want to shutdown, and the upgrade/updates don’t want to run either.

If someone has any interest in a zoom call/screen share, I can arrange that. If there’s a fee for time, I’m open to discussing.


Is there anything in the logs that might hint as to what’s causing the issue?

I can check, I’m at a bit of a loss as to which log to check as I can’t quite tell where I’m getting hung up other than running the updates, and as best I can tell, some updates ran and threw the system into this intermediary space where some packages are stuck waiting on other updates - chick and egg world.

Is there a particular log file you think would be more helpful given the current details?

Try /var/log/asterisk/full

Not sure if it will let me post a link to the log or not…

This file includes both the readout from update all, and it’s various complaints, as well as (at the bottom), the log file details from the moment I switched to version 19.

Anything seem odd? The errors I see are about loading conf files, but not sure if that’s due to those modules not being updated and disabled?

Also, even after switching to 19, the system still throws that version 0 error.


PS Whereabouts in the UK are you, Richard? I used to work for a company based out of Salisbury.

For what it’s worth, when I do a google search for:

asterisk “Unsupported Version of 0”

This is the only post that seems to exist.

But it seems to be related to asterisk not installing, where in my case it’s installed and is running version 19.

Just sharing more info in case it’s helpful.

I’m in Reading, although used to run a business in Salisbury about 10+ yrs ago!

Having a dig around you could try re-installing the framework module, alternatively if it’s a new system it might be quicker and easier to download the latest iso and do a fresh install.

I was at MNP, pretty sure they around then (2014 to 2020 for me I think).

I think I’d prefer to go with the ISO install.

  1. Where would I find the proper ISO for the FreePBX 40?
  2. Are there any guides on the install process to go with it?

Been awhile since I last used Asterisk (pre FreePBX days). Would like to just get a crash course refresher. :slight_smile:

To clarify, in purchasing the FreePBX 40, are there certain features I get from that hardware that I need to be sure I obtain the proper ISO to use?

Really appreciate the help!

Hmm, I’ve maxed out on my replies… thanks for the info on the ISO, I’ll get started.

9/3/22 - 2:30p ET
Quick update, The FreePBX 40 box is re-installed from clean ISO. Will see how things go now and will report back.

2:50p ET - Update
I was able to log into the web interface, and then it walked through updates, then activation, all seemed fine. Walking through the Firewall wizard and it through an Ajax error when enabling the local network as trusted, then dropped the SSH connection and browser connection. :confused:

Made it a couple more steps and then… “Ajax request broken or aborted for an unexpected reason. Please check console logs for more details.”

Kind of crummy to require new users to limit their interactions on their own thread when aiming to get support from a newly purchased device. Frustration level increasing a bit.

I can’t imagine this is the experience this box is meant to deliver and I question whether it’s in proper working order. It certainly isn’t leaving me with a lot of confidence of setting up a small office to rely on it for their daily communications.

Assuming this isn’t normal behavior for a FreePBX 40, should I aim to return it and get a new box?

3:11p ET
Looks like the system just did it’s own reboot.

4:43p ET
Got the PBX connected to the SIP provider using pjsip. I have one phone here on hand connected to the PBX. Now just need to get inbound and outbound dialing to work.

Kind regards

It’s just the standard iso available from Just choose v16 and use etcher or something to flash to usb. Lots of documentation on If you’ve bought as PBXact appliance or with commercial modules the you will need to remember to re-activate with existing deployment.

Appliances don’t have anything different in terms of software build.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.