New did is not recognizing in system

Hi all.

Need a bit of help, not really sure how to explain the problem.
I have pri with 100 block did , I have several in the system and they are ringing to the right extensions, but today I tried to enter a new did to use the Freepbx fax module, the problem is no matter what did I enter it ends up in my catch all main ivr, I have even directed it to faxes, I have directed it to other extensions, and for some reason is still ends up in my catch all. Is there a file in asterisk that would override the files in freepbx…

Example I enter did 713-457-0988 and send to fax reciepent ends in general catch all, I enter 713-457-2241 it goes to general catch all.

I set up new extension, no problem, even enable outside sip and it connects and can use the system , so that is working right

The did is showing in the inbound routes but still is going to general catch all, Hope this explains my problem , very new at this and still learning , any help is appreciated

It sounds as if the fax tone is not being detected so the call is being treated as a voice call and if you dont have a specific inbound route set up for that did it will go to the catch all. There was a fax thread a month or so ago about fax detection that might be worth reading.

That when I put a new did in the freepbx gui , it is registering in the gui, but in fact and is showing registered to an extension, but is not really happening in asterisk.

In other words asterisk doesn’t is sending the call to any/any and not to the did route in freepbx. Hope that is clearer, sooo frustrated, but last piece of a broken puzzle that is final close to perfect,

Make sure your any/any route doesn’t have “CID Priority Route” checked. Also if you have a route for “any DID / [# of phone you are calling from]”, make sure it doesn’t have that box checked.

I’ve had problems with inbound DID routes that have an IVR destination. They sometimes require “Signal RINGING.” That shouldn’t be your problem if the calls are getting into the system, but it’s worth a try.

Mike

Update: Just read the whole thing and would like to apologize for my un-informed comment. Have you tried modifying a working DID with the new number? Also, if you remove a working DID route, does it stop working?

I checked all of the above deleted the route and reinstalled it , it shows in free pbx but this is what asterisk is seeing

-- Executing [[email protected]:1] NoOp("DAHDI/i2/7134570830-6", "Catch-All DID Match - Found 0988 - You probably want a DID for this.") in new stack
-- Executing [[email protected]:2] Goto("DAHDI/i2/7134570830-6", "ext-did,s,1") in new stack
-- Goto (ext-did,s,1)
-- Executing [[email protected]:1] Set("DAHDI/i2/7134570830-6", "__FROM_DID=s") in new stack

bump

Go into the mysql tool (find credentials in /etc/asterisk/freepbx.conf

Enter the following commands:

use asterisk;
select * from incoming;

post the results using the [code]tags[/code] so we can read it.

Is empty?

what should be in this file?