Never Override CallerID problem


I try to customize the outbound caller ID I use.

I have set up caller IDs in my extentions but I want a specific trunk to use another caller id (one for all extensions). So I filled in the Never Override CallerID option with the number I want to use…but still it uses the caller ID of the extention.

How can I fix that ?

Thank you…

I was doing some experimentation last week and discovered the exact same thing - I just chalked it up to expected behavior at the time (extension rule overrides trunk rule) but now that I think more about it, it probably shouldn’t be that way. Look in the left hand column on this page and go to Development Site | Report Bug and fill in a bug report, if you think this is not the way it should be operating.

(In my case, I actually looked at the CLI and saw the CID get set to the trunk-specified value, and then about two or three lines later get reset to the extension value. Since I was doing something a bit unorthodox, I wasn’t willing to call it a bug right at that moment in time, and then forgot about it).

Thanks for your answer, I’ve reported the bug.

It is the way it should be. The label is probably a bit mis-leading but the tool tip should clarify what the feature does and why. You desired feature does not exist although there is probably a feature request amongst the many (but if not, you are welcome to add it).

for your answer… I didn’t understood that way…

I’m brand new at this and not sure if I am answering your question or not. I tried to set a specific outbound CID for all my calls the same way that you did and it didn’t work. I was told to do it this way and it did work

I went into FreePBX and selected

tools>config edit>agi-conf1

then scrolled down til I found these 2 lines

; enable the setup of the callerID number before the outbound is made, by default the user callerID value will be use
auto_setcallerid = YES
(make sure that is YES)

; If auto_setcallerid is enabled, the value of force_callerid will be set as CallerID
force_callerid = **********
(replace the * with the outbound CID you want)

“Never Override CallerID” is still checked in the trunks setting and I also have the same number in the “Outbound Caller ID” field (Trunks) as I do in the agi-config1 I listed above.

It now passes the CID I want to the called party.
Hope this helps

Indeed it works very well…but it passes the same CID to all the trunks. What I wanted to do is to set a °always use this CID when use this particular°… I now what I’d like to do is somehow complicated but…

Thanks again, this might helps others more than me :wink: