Need help with two trunks and two outbound routes

freepbx
configuration
siptrunk
Tags: #<Tag:0x00007f702814e908> #<Tag:0x00007f702814e520> #<Tag:0x00007f702814e188>

(India) #1

Hi,

I am using freepbx 14 with two sip trunks(same provider).
I have configured first trunk very easily and both in-out calls are working perfectly
Now i have added another trunk configuration with one more outbound route but shows problem with outbound cid as all outbound calls are directed via first trunk.
Please help me how to configure two trunks to work with separate outbound routes.

Thanks in advance


(Itzik) #2

If both outbound routes have identical dial patterns then the PBX will start with the first route and obviously won’t try other if it succeeded.

I am not sure what you are trying to accomplish and why you would want to have two trunks from the same provider, but by guessing I would say that the best option is to use a prefix which you will specify on the second outbound route.


(India) #3

Thank you for your reply.

The story is,

I am using this system since two years with one trunk and it is working.

Netowork overviews
E1 line --> PRI gateway (pri to sip trunk) --> freepbx
Working fine

Due to shortage of channels we have purchased new e1 line and the setup is given below
Now 2 x E1 line --> PRI gateway ( pri to sip trunk) --> freepbx ( configured two sip trunks respected to each E1 line with two out routes respected to each sip trunk)

  1. 672300 extension is showing outbound cid matched with first e1 line but when i dial 668600 it shows outbound cid 672300
    The problem is when i dialing out second trunks DID it is going via first trunk.
    Please give me an idea about how to configure outbound route to use respected trunk

Thank you


(Itzik) #4

If there issue is a channel shortage, then use one outbound route and add both Trunks to that outbound route.
In both Trunks enable continue if busy.

Once the first Trunk is full, outgoing calls will automatically start going though the secondary.


(system) closed #5

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.