Need help with SPA3000 registering as trunk


(United States) #1

I need some help getting my cisco SPA3000 back up after I did a reinstall of Freepbx. I cannot get the PSTN line to re-register with the PBX. I am using this SPA3000 to make and receive phone calls. Thanks for the help in advance!


#2

The combination of
host=dynamic
and
port=5160
is not supported and might be causing your issue. Remove the port= line.
If that doesn’t help, check that PBX IP address is 10.0.161.115 and Bind Port for chan_sip is 5160.

If you still have trouble, check whether anything appears in the Asterisk log when the SPA attempts to register. If so, at the Asterisk command prompt type
sip set debug on
and look at the REGISTER requests and replies for problems.

If nothing is logged, the FreePBX firewall might be blocking it; check settings or try turning it off for test. You can use sngrep or tcpdump to see whether REGISTER requests are reaching the PBX.

I assume that the SPA has a 10.0.161.x address and there is nothing but dumb switches between SPA and PBX. If not, please describe your network.


(United States) #3

Removed the port line and verified that 5160 was the chan sip registration port. Still no registration. Here is from what I understand is the registration attempt from the SPA


#4

The section of log you posted has no chan_sip related entries at all. The from-sip-external stuff might be malicious traffic probing your system, or incoming calls on a misconfigured SIP trunk.

Note the time, reboot the SPA, wait for the Info page to be accessible and show registration failed. Then examine the Asterisk log and look starting from the reboot time.

For posting a large log section, paste the text at https://pastebin.freepbx.org and post the link here.

If the Asterisk log shows no registration attempt, look with tcpdump. Or, set SIP Debug Option on the SPA to full (and set up Debug Server on the System page); run Wireshark (or a syslog server) on your PC to view the SPA’s SIP traffic.


(United States) #5

There does seem to be something a little odd now that you pointed that out. All the users that are online are phones that I have registered, but the dashboard is reporting 30-60 channels are in use at some given points in time. I’m just going to reinstall the newest distro. What should the peer details look like for the SPA?


#6

This was an example FPBX config that is working on my current setup

username=SPA3000
type=friend
secret=thepassword
qualify=yes
port=5061
incominglimit=1
host=dynamic
dtmfmode=rfc2833
disallow=all
canreinvite=no
allow=ulaw&alaw

Not sure if it makes a difference but I had the trunk Name the same as the username field.

Darn I forgot the admin PW for the SPA3000, to show the config in that.
Once I remember I shall post if still needed

Hv.


(United States) #7

Worked perfectly with your definitions. Not sure what is in there that made it a winner, but it took it.


#8

Sorry, I missed the lack of
type=friend
I have no idea what, if anything, a trunk without a ‘type’ will do, though I would think that registration attempts would still be logged.


(United States) #9

Ah, that is probably what was missing
I deleted that install already. It’s a clean new one now. Thanks for your help again Stew


(system) closed #10

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.