Need help with Class Of Service module


(Bob Reiber) #1

I had to run the conversion tool and move this PBX and now all the extensions that in the particular class of service aren’t working correctly. Originally this was set up to prevent certain extension from dial x3000 (which is the ATA that ties into the paging system) and it was working up until recently. I’m seeing this in the asterisk logs

Call from ‘1135’ (x.x.x.x:5060) to extension ‘2474835’ rejected because extension not found in context ‘not-3000’.

Not sure where that context would be defined. How do I create a context to prevent the dialing of x3000?


(Itzik) #2

COS Cannot block ext to ext calls.

You probably had some configuration in the custom context module.


(Dave Burgess) #3

I’m getting old, but didn’t we help you put that context together a couple of years ago? Check your old extenions_custom and see if it’s in there. Chances are, it was something we all helped you with.


(Bob Reiber) #4

Probably something my dad did a few years ago. Unfortunately he’s not around anymore to ask about it. Looking at the old broken server now.


(Bob Reiber) #5

Can you find the link to the thread? I dug up pieces of custom context from extensionsadditional.conf but I dont know if this is all of it.

[not-3000]
include => not-3000-custom
include => outbound-allroutes
include => outrt-2
include => outrt-4
include => outrt-1
include => outrt-3
include => not-3000_bad-number
include => bad-number
exten => _11xx,1,Goto(not-3000_rulematch,${EXTEN},1)

exten => _31xx,1,Goto(not-3000_rulematch,${EXTEN},1)

exten => _32xx,1,Goto(not-3000_rulematch,${EXTEN},1)

exten => _40xx,1,Goto(not-3000_rulematch,${EXTEN},1)

exten => _60xx,1,Goto(not-3000_rulematch,${EXTEN},1)

exten => s,1,Macro(hangupcall,)

exten => h,1,Macro(hangupcall,)

;–== end of [not-3000] ==–;

[not-3000_rulematch]
include => not-3000_rulematch-custom
include => parkedcalls
include => from-internal-custom
include => app-cf-busy-off
include => app-cf-off
include => app-cf-busy-prompting-on
include => app-cf-busy-on
include => app-cf-busy-off-any
include => app-cf-off-any
include => app-cf-on
include => app-cf-toggle
include => app-cf-unavailable-prompt-on
include => app-cf-unavailable-on
include => app-cf-prompting-on
include => app-cf-unavailable-off
include => ext-cf-hints
include => app-callwaiting-cwoff
include => app-callwaiting-cwon
include => ext-meetme
include => app-daynight-toggle
include => app-dictate-record
include => app-dictate-send
include => app-dnd-off
include => app-dnd-on
include => app-toggle
include => ext-dnd-hints
include => app-fax
include => app-fmf-toggle
include => ext-findmefollow
include => fmgrps
include => app-hotelwakeup
include => app-calltrace
include => app-echo-test
include => app-speakextennum
include => app-speakingclock
include => ext-intercom-users
include => park-hints
include => app-parking
include => app-pbdirectory
include => ext-queues
include => app-recordings
include => ext-group
include => grps
include => app-speeddial
include => vmblast-grp
include => app-dialvm
include => app-vmmain
include => app-blacklist
include => app-userlogonoff
include => ext-local-confirm
include => findmefollow-ringallv2
include => app-pickup
include => app-chanspy
include => ext-test
include => ext-local
include => outbound-allroutes
include => outrt-2
include => outrt-4
include => outrt-1
include => outrt-3
include => not-3000_bad-number
include => bad-number
exten => s,1,Macro(hangupcall,)

exten => h,1,Macro(hangupcall,)

;–== end of [not-3000_rulematch] ==–;

[not-3000_bad-number]
include => not-3000_bad-number-custom

;–== end of [not-3000_bad-number] ==–;


(Itzik) #6

What do you see in the custom context module?


(Bob Reiber) #7

Nothing because the old server is broken. I cant even SSH in. I looked at the contents of the file in the hypervisor and copied those lines.


(Itzik) #8

Install it (if it’s not already) on the new PBX and see if it has anything.


(Bob Reiber) #9

Theres nothing there.


(Bob Reiber) #10

How do I get rid of that damned context? I’m seeing this

[2019-10-17 13:58:34] NOTICE[1642][C-0000001e]: chan_sip.c:26458 handle_request_invite: Call from ‘1117’ (x.x.x.x:5060) to extension ‘3102’ rejected because extension not found in context ‘not-3000’.


(Bob Reiber) #11

I found where its looking for that context, but can I just change it in that text file? I don’t see it in the extension page in the GUI anywhere.

grep -s -R not-3000 /etc/*

/etc/asterisk/sip_additional.conf:context=not-3000
/etc/asterisk/sip_additional.conf:context=not-3000
/etc/asterisk/sip_additional.conf:context=not-3000
/etc/asterisk/sip_additional.conf:context=not-3000
/etc/asterisk/sip_additional.conf:context=not-3000
/etc/asterisk/sip_additional.conf:context=not-3000


(Lorne Gaetz) #12

Check on the Advanced tab for the extension and see what the ‘context’ field is set to. It should be from-internal


(Bob Reiber) #13

That’s the problem, I cant see that. I feel like it used to be there. And I cant find anything in advanced settings to that effect.

FreePBX 14.0.10.3
Asterisk 13.22.0


(Bob Reiber) #14

I ended up importing the settings in the bulk handler.

Not sure why I cant see the Context field. Will try running updates later and see if it at least reappears.