Need help on Installation

  1. Am using CentOS 5.4…
    Linux mmelabpc-01.migv.mot.com 2.6.18-164.el5 #1 SMP Thu Sep 3 03:33:56 EDT 2009 i686 i686 i386 GNU/Linux

  2. Following the steps mentioned in the link to install Freepbx
    http://www.freepbx.org/support/documentation/installation/install-process-for-centos-5-1

  3. I got stuck in this step…
    cd /usr/src/dahdi-linux-complete-CURRENT
    make [worked fine , i dint get any error]
    make install [worked fine, i dint get any error]
    make config [am getting an error saying No hardware found, can you plz let me know if have done some mistake??]

make[3]: Leaving directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools/xpp' make[2]: Leaving directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools’
make[1]: Leaving directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools' make -C linux install make[1]: Entering directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux’
make -C drivers/dahdi/firmware firmware-loaders
make[2]: Entering directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/firmware' make[2]: Leaving directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/firmware’
make -C /lib/modules/2.6.18-164.el5/build SUBDIRS=/usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi DAHDI_INCLUDE=/usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/include DAHDI_MODULES_EXTRA=" " HOTPLUG_FIRMWARE=yes modules DAHDI_BUILD_ALL=m
make[2]: Entering directory `/usr/src/kernels/2.6.18-164.el5-i686’

Building modules, stage 2.
MODPOST
WARNING: could not find /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/vpmadt032_loader/.vpmadt032_x86_32.o.cmd for /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/vpmadt032_loader/vpmadt032_x86_32.o
make[2]: Leaving directory /usr/src/kernels/2.6.18-164.el5-i686' build_tools/uninstall-modules dahdi 2.6.18-164.el5 make -C /lib/modules/2.6.18-164.el5/build SUBDIRS=/usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi DAHDI_INCLUDE=/usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/include DAHDI_MODULES_EXTRA=" " HOTPLUG_FIRMWARE=yes INSTALL_MOD_PATH= INSTALL_MOD_DIR=dahdi modules_install make[2]: Entering directory/usr/src/kernels/2.6.18-164.el5-i686’
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_dummy.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_dynamic.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_dynamic_eth.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_dynamic_loc.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_echocan_jpah.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_echocan_kb1.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_echocan_mg2.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_echocan_sec.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_echocan_sec2.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_transcode.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/dahdi_vpmadt032_loader.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/pciradio.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/tor2.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/voicebus/dahdi_voicebus.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/wcb4xxp/wcb4xxp.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/wcfxo.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/wct1xxp.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/wct4xxp/wct4xxp.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/wctc4xxp/wctc4xxp.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/wctdm.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/wctdm24xxp/wctdm24xxp.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/wcte11xp.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/wcte12xp/wcte12xp.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/xpp/xpd_bri.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/xpp/xpd_fxo.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/xpp/xpd_fxs.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/xpp/xpd_pri.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/xpp/xpp.ko
INSTALL /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/xpp/xpp_usb.ko
DEPMOD 2.6.18-164.el5
make[2]: Leaving directory /usr/src/kernels/2.6.18-164.el5-i686' [id -u= 0 ] && /sbin/depmod -a 2.6.18-164.el5 || : install -d /etc/udev/rules.d build_tools/genudevrules > /etc/udev/rules.d/dahdi.rules install -m 644 drivers/dahdi/xpp/xpp.rules /etc/udev/rules.d/ for hdr in kernel.h user.h fasthdlc.h wctdm_user.h dahdi_config.h; do \ install -D -m 644 include/dahdi/$hdr /usr/include/dahdi/$hdr; \ done make -C drivers/dahdi/firmware hotplug-install DESTDIR= HOTPLUG_FIRMWARE=yes make[2]: Entering directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/firmware’
Firmware dahdi-fw-oct6114-064.bin is already installed with required version 1.05.01
Firmware dahdi-fw-oct6114-128.bin is already installed with required version 1.05.01
Firmware dahdi-fw-tc400m.bin is already installed with required version MR6.12
make[2]: Leaving directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/firmware' make -C drivers/dahdi/xpp/firmwares install make[2]: Entering directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/xpp/firmwares’
mkdir -p /usr/share/dahdi
install …/init_card_1_30 …/init_card_2_30 …/init_card_3_30 …/init_card_4_30 /usr/share/dahdi/
install -m 644 …/XppConfig.pm USB_FW.hex FPGA_FXS.hex FPGA_1141.hex FPGA_1151.hex FPGA_1161.hex PIC_TYPE_1.hex PIC_TYPE_2.hex PIC_TYPE_3.hex PIC_TYPE_4.hex /usr/share/dahdi/
make[2]: Leaving directory `/usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/xpp/firmwares’
###################################################

DAHDI installed successfully.

If you have not done so before, install the package

dahdi-tools.

###################################################
make[1]: Leaving directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux' make -C tools install make[1]: Entering directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools’
make[2]: Entering directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools' make[3]: Entering directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools/xpp’
make[3]: Nothing to be done for all'. make[3]: Leaving directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools/xpp’
make[2]: Leaving directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools' make[2]: Entering directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools/xpp’
make[2]: Nothing to be done for all'. make[2]: Leaving directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools/xpp’
make[2]: Entering directory `/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools/xpp’
/usr/bin/install -c -d /usr/sbin
/usr/bin/install -c fpga_load astribank_tool astribank_hexload astribank_allow astribank_is_starting dahdi_registration xpp_sync lsdahdi xpp_blink dahdi_genconf dahdi_hardware twinstar /usr/sbin/
/usr/bin/install -c -d /usr/share/dahdi
/usr/bin/install -c xpp_fxloader astribank_hook /usr/share/dahdi/
/usr/bin/install -c waitfor_xpds /usr/share/dahdi/
/usr/bin/install -c -d /usr/share/man/man8
/usr/bin/install -c -m 644 fpga_load.8 astribank_tool.8 astribank_hexload.8 astribank_allow.8 astribank_is_starting.8 dahdi_registration.8 xpp_sync.8 lsdahdi.8 xpp_blink.8 dahdi_genconf.8 dahdi_hardware.8 twinstar.8 /usr/share/man/man8/
/usr/bin/install -c -d /etc/hotplug/usb
/usr/bin/install -c -m 644 xpp_fxloader.usermap /etc/hotplug/usb/

for backward compatibility and for hotplug users:

ln -sf /usr/share/dahdi/xpp_fxloader /etc/hotplug/usb/
/usr/bin/install -c -d /usr/lib/perl5/site_perl/5.8.8
for i in Dahdi Dahdi/Hardware Dahdi/Config Dahdi/Config/Gen Dahdi/Xpp;
do
/usr/bin/install -c -d “/usr/lib/perl5/site_perl/5.8.8/$i”;
done
for i in Dahdi.pm Dahdi/Chans.pm Dahdi/Hardware.pm Dahdi/Span.pm Dahdi/Utils.pm Dahdi/Xpp.pm Dahdi/Hardware/PCI.pm Dahdi/Hardware/USB.pm Dahdi/Config/Gen.pm Dahdi/Config/Params.pm Dahdi/Config/Gen/Chandahdi.pm Dahdi/Config/Gen/Modules.pm Dahdi/Config/Gen/System.pm Dahdi/Config/Gen/Unicall.pm Dahdi/Config/Gen/Users.pm Dahdi/Config/Gen/Xpporder.pm Dahdi/Xpp/Line.pm Dahdi/Xpp/Mpp.pm Dahdi/Xpp/Xbus.pm Dahdi/Xpp/Xpd.pm;
do
/usr/bin/install -c -m 644 “perl_modules/$i” “/usr/lib/perl5/site_perl/5.8.8/$i”;
done
make[2]: Leaving directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools/xpp' install -d /usr/sbin install fxotune sethdlc dahdi_cfg dahdi_monitor dahdi_speed dahdi_test dahdi_scan dahdi_tool /usr/sbin/ install -d /usr/share/man/man8 install -m 644 doc/fxotune.8 doc/dahdi_cfg.8 doc/dahdi_monitor.8 doc/dahdi_test.8 doc/dahdi_scan.8 doc/dahdi_tool.8 /usr/share/man/man8/ /usr/bin/install -c -D -m 755 libtonezone.a /usr/lib/libtonezone.a /usr/bin/install -c -D -m 755 libtonezone.so /usr/lib/libtonezone.so.2.0 if [id -u` = 0 ]; then
/sbin/ldconfig || : ;
fi
rm -f /usr/lib/libtonezone.so
/bin/ln -sf libtonezone.so.2.0
/usr/lib/libtonezone.so.2
/bin/ln -sf libtonezone.so.2.0
/usr/lib/libtonezone.so

Overwrite the 1.0 links out there. dahdi-tools 2.0.0 installed

1.0 links but dahdi-tools changed them to 2.0 in order to explicitly

break applications linked with zaptel. But, this also meant that

applications linked with libtonezone.so.1.0 broke when dahdi-tools

2.1.0 was installed.

/bin/ln -sf libtonezone.so.2.0
/usr/lib/libtonezone.so.1.0
/bin/ln -sf libtonezone.so.2.0
/usr/lib/libtonezone.so.1
/sbin/restorecon -v /usr/lib/libtonezone.so
/usr/bin/install -c -D -m 644 tonezone.h /usr/include/dahdi/tonezone.h
###################################################

DAHDI tools installed successfully.

If you have not done so before, install init scripts with:

make config

###################################################
make[1]: Leaving directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools' make -C tools config make[1]: Entering directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools’
install -D dahdi.init /etc/rc.d/init.d/dahdi
install -D ifup-hdlc /etc/sysconfig/network-scripts/ifup-hdlc
/sbin/chkconfig --add dahdi
DAHDI has been configured.

List of detected DAHDI devices:

No hardware found
make[1]: Leaving directory `/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools’
[[email protected] dahdi-linux-complete-2.2.1+2.2.1]# make config >> /usr/src/log.txt
WARNING: could not find /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/vpmadt032_loader/.vpmadt032_x86_32.o.cmd for /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/vpmadt032_loader/vpmadt032_x86_32.o
WARNING: could not find /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/vpmadt032_loader/.vpmadt032_x86_32.o.cmd for /usr/src/dahdi-linux-complete-2.2.1+2.2.1/linux/drivers/dahdi/vpmadt032_loader/vpmadt032_x86_32.o
[[email protected] dahdi-linux-complete-2.2.1+2.2.1]# vi /usr/src/log.txt
/usr/lib/libtonezone.so.1
/sbin/restorecon -v /usr/lib/libtonezone.so
/usr/bin/install -c -D -m 644 tonezone.h /usr/include/dahdi/tonezone.h
###################################################

DAHDI tools installed successfully.

If you have not done so before, install init scripts with:

make config

###################################################
make[1]: Leaving directory /usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools' make -C tools config make[1]: Entering directory/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools’
install -D dahdi.init /etc/rc.d/init.d/dahdi
install -D ifup-hdlc /etc/sysconfig/network-scripts/ifup-hdlc
/sbin/chkconfig --add dahdi
DAHDI has been configured.

List of detected DAHDI devices:

No hardware found
make[1]: Leaving directory `/usr/src/dahdi-linux-complete-2.2.1+2.2.1/tools’

Do you have any?