Need help. Not able to set outbound dial pattern

I am not able to make local outbound calls from my Bria softphone. International calling is working fine.
I tried +61 Australian number. But the same number when I dial in local pattern, Its not working.
Number is like: +6128365XXXX (working)
Number like: 028365XXXX(not wokring- Getting declined 603 error).

How should I set the dial pattern to work both the patterns. Current dial pattern attached.

I believe that your fourth pattern correctly transforms the domestic pattern into E.164 format, so it appears that your provider will not accept E.164, either at all or for domestic calls.

The third pattern correctly converts E.164 to domestic, and it’s working.

So, we want to present them with 0XXXXXXXXX for all domestic calls, whether originally dialed that way or dialed as E.164.

The first pattern should have
prepend (blank); prefix (blank); match pattern 0[1-9]XXXXXXXX

Delete the second and fourth patterns and test.

Now, if you want to be able to dial just 8365XXXX, you should add:
prepend 02; prefix (blank); match pattern [2-9]XXXXXXX

Eventually, you will want to add patterns for emergency, short codes and international calling.

Although that was unlikely the intention, albeit it is of diagnostic value.

It doesn’t make sense to have two rules which perform the opposite translation, as, if they were valid, you would get the same effect by matching both formats without any prefix or prepend.

Hi Bro,

It didnt work. I tried both the patterns as shown in the screenshot. Any other dial set do you suggest me to try?

Paste the Asterisk log for a failing call at and post the link here.
If the caller hears “All circuits are busy now” (provider rejected call), turn on pjsip logger before making the test call.

The out bound calls are not connecting at all.

Asterisk log URL: Failed call log - FreePBX Pastebin

I have pasted three logs, First two logs are of failed calls when I dialled without +61.
Third log is of a successful call when I dialled with +61.

I suspect you have another route that is matching the number.

The issue is very clear. The restricted route doesn’t exist.

[2023-02-15 21:35:06] WARNING[34055][C-0000635b] pbx.c: Channel ‘SIP/002-000011ce’ sent to invalid extension but no invalid handler: context,exten,priority=restrictedroute-c37990a2cecdbb23e1ef2e663e5732f0,0438673385,2

It appears that you have the Extension Routing module installed. By default, all Outbound Routes are Blocked to all extensions, unless you have explicitly Allowed them.

However, this is still strange because I would assume that all three calls would match the same route (one you set up for normal domestic numbers). So it appears that the failing calls are indeed matching (as @BlazeStudios said) a different route which is not marked as Allowed for extension 002.


So, could you please tell me what change should I make to get all the extensions working. I can’t see an option to allow outbound calling/route separately for the extensions.
I am using Asterisk FreePBX

If you have the Extension Routing or Class of Service modules installed but don’t intend to use them (you have no need to restrict some extensions from calling certain destinations), I recommend you remove them. Otherwise, see the documentation Extension Routing-Admin Guide - PBX GUI - Documentation .

If your +61xxxxxxxxx and 0xxxxxxxxx match different Outbound Routes, that should not be needed and you should set up one ‘domestic’ route including both patterns, as discussed in earlier posts.

If you still have trouble, post a screenshot of the Dial Patterns tab of your Outbound Route.

Unrelated to your issues. Consider upgrading to a supported version. The version you are using is EOL for a couple of years already.

He’s done that. What he needs to do is post this information for all the outbound routes.

Hi Stewart,

As you mentioned there was an extension routing module installed. I checked it and modified as per the requirement and it is working fine now. Thank you Stewart/all, for your valuable time and advise.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.